DAHDI audio problem with analog OpenVOX A400E FXO card

I have a FreePBX Distro v10 (Asterisk v13) 64bit and an OpenVOX A400E with one FXO & one FXS cards.
I am using the FXO card to interface my IPPBX with my PSTN phone number provided from my ISP, but i have audio problems only from the phone that is attached to my IPPBX (Cisco SPA232D ATA with analog phone & Fanvil C60 voip phone). The other side has perfect audio quality! My side has a distortion at the end off the echo tail so when i speak simultaneously with the other end i here the distortion at the end off the echo tail and i can’t here the other end.
I have echo cancellation enabled (OSLEC).
My hardware:
Motherboard ASUS C8HM70- I with dual core celeron 1.1GHz CPU (mini ITX),
SSD Kingston SV300S37A60G V300 HDD, RAM 4GB.
My question:
Is this problem because of hardware performance (probably CPU)?
Thank you very much in advance!

I am having the exact same problem, distortion disappears if i turn off EC, but echo becomes very pronounced…

Impedance matching and 2-4 wire hybrid balancing against a standard milliwatt test will help

i have narrowed down the problem to a possible faulty card. i have two cards in the box, TDM800 (4fxs 4fxo) and TDm400 (4fxo). it seems that the problem is with the TDM400. validating and will post again after running extensive tests.

it looks like the problem is solved by only using the TDM800, i tried only using the TDM400 and the distorted echo persisted. i still need 2 FXO ports so i will try swapping the FXS card of the 800 with the FXO card of the 400 to have 8FXO on the 800 and 4FXS on the 400. if the problem comes back i will know it is due to a faulty FXO card, otherwise it must be the TDM400 that is faulty or Freepbx that is having some issues with multiple cards…

finally the problem is not resolved yet, the distorted echo is less pronounced but intermittently it comes back. it is definitely linked to the the echo cancellation, removing the echo cancellation removes the distortion but introduces echo to the call…

after much coffee, sweat, and hair pulling i fell on this amazing post >>> http://kb.digium.com/articles/Troubleshooting/how-to-basic-fxotune

FXOTUNE ROCKS! problem solved just like that!