Custom Unvailable Greeting Design


I am trying to design a voicemail system for my 150 snom300 phone with FreePBX 2.11.0 version.

What I have done so far is:

  1. Already Created 150 extensions for all snom300 phone.
  2. Created Unavailable Greetings using TTS software.

Now I have done is that for example, I uploaded one unavailable greeting for extension 505, /var/spool/voicemail/default/505/
with the name “unavail.wav”. And when I tested it played well but once it finishes the default voice(please leave your message after the tone, when done hangup…) getting played. I tried to disable this from FreePBX GUI under VoiceMail Admin/behaviour then checking the first option,but what happened then is that my custom greeting gets played followed by tone sound and after this when I record the message and press # key or hangup, there is no voicemail in 505 extension.

I don’t know what wrong I am doing.

I just want to implement a custom voicemail system for my company and there requirement is that they want to hear male sound for male’s extension and female sound for female’s extension along with there name and company name.

Please help, because I need to implement this within 3-4 days.


What version of FreePBX are you using? Distro or hand built? What exact settings have you changed? As Skyking said “logs?”

Dicko said logs…hehe

But Scott would have said the same thing if he came here first :wink:

I have created a .wav file and named it as unavail.wav and copied that file to extension 105/. then tried to listen not working. then tried to “chmod ug+wrx unavail.wav”, not working.

The thing is that when I add this file, the default one which “the person as extension…” is skipped also and only “please leave your message after the tone…” is played.

Deleted the entire mailbox, recreated and copied the unavail.wav file to the location and still same issue.

the format of the .wav format must be very explicit, 8k samples, 16 bit unsigned and mono, it must be readable by the asterisk user. If you do that it should be honored. Use sox to ensure that.

1 Like

Here is what I did…

unavail.wav file property from VLC Media Player.

Stream 0
Type: Audio
Codec: PCM S16 LE (araw)
Channel: Mono
Sample Bit Rate: 8000 Hz
Bits per sample: 16

and in linux I run this command “chmod ug:rwx unavail.wav”

but when I am playing its not recognizing the file even.