Custom Ringtones Locking Up phone


I’ve uploaded 5 ringtones to an S700 with the expansion module attached. Whenever I test play any of those ringtones I get a loud hum at the end and the screen starts having a bright line move from top to bottom and then finally the phone locks up. When I do the same test on an S700 with OUT the expansion module I still get the hum at the end but the phone continues to work.

Seperately there is one file that one it’s uploaded to FreePBX it is so garbled that it’s unusable. It’s a file called Warble.wav and it comes with Polycom phones.

EPM 13.0.083 and phone firmware and EXP100 firmware

Try with MP3s as I can not replicate and only have MP3s. Also are you sure your files are under 15 seconds?

I will try MP3’s next. I am sure they are less then 15 seconds.

Here are some links to two of the ringtones I’ve been working with.

This is the Merlin Ringtone
Removed for security reasons

This is the Warble One
Removed for security reasons

You are correct. MP3’s work fine. Only the WAV files are having this issue. You can download the samples I linked to my previous reply.


I can also make a phone with an EXP100 attached lockup and/or reboot if you have feedback on a call. For example answering a portable phone next to the S700 in speaker mode. The feedback will lock up or reboot the phone and EXP100.

I have no clue how to even reproduce this but please use our bug tracker for reporting things. under the phone project.

Here’s the issue listing.

I think you can recreate this by uploading the WAV file I attached to the issue. Then just making it playback from the volume control button.

Is there anything special you need to do with the Sangoma phones to get the custom ringtones to work?

I’ve uploaded a custom ringtone, as an mp3, less than 15 seconds, applied it to the phone and rebooted the phone. I can confirm that it says “ring6” in the ringtone list, but it rings with ringtone 5 whenever i dial. I can’t get it to use the custom mp3.

Did you also select Ring6 as the default ringtone in the Endpoint Manager? Specifically in the Options tab for that phone’s template?

I have yes.

Also this is on the S500 model, i presume custom ringtones aren’t restricted to the S700 only?

EDIT: What does your “Ring server path” show on the phones under the management > auto provision page, on the phones themselves?

EDIT2: It’s ok, i fixed it. It doesn’ work if provisioning method is set to TFTP, set it to HTTP and it works.

Glad you got it working. I had trouble with TFTP as well and switched to HTTP.

I’ve just been testing a few things today and found that all the phones when switched over to http would randomly drop off endpoint manager, logging into the phone showed “Registration failed” in their account page. Changing back to TFTP seems to put it right again…

Not sure why that is, however i did find that in system admin, under port management, the bottom 3 choices weren’t set to their defaults and were instead mixed up, for example HTTP provisioning was set to 82, rather than the default of 84 etc. I haven’t changed this myself though so I’m unsure how that came about. Yet to test it again since putting that right, might give that a go later today.