Custom pjsip extension

Hi All,

I have a custom extension set up that allows me to dial a users cell phone as if it were an internal extension (ie. ext 700). This has always worked fine and the extension is defined as a type “custom”.

In order to direct the call, in the Extention’s “Advanced” tab, I have the following in the “Dial” field:
SIP/Flowroute/15558675309

Where “Flowroute” is the name of the SIP trunk I want to use.

I had to switch my trunks from SIP to PJSIP and now this extension no longer works. My new trunk is called “Flowroute-pjsip” so I changed the “Dial” field to:
SIP/Flowroute-pjsip/15558675309

And that doesnt work.

I also tried changing it to things like:
PJSIP/Flowroute-pjsip/15558675309
SIP/sip.flowroute.com/15558675309
15558675309

And none of those work either.

How do I make this extension work with PJSIP using a specific trunk? Or heck, any trunk for that matter… right now nothing is working!

Thanks to all in advance.

For the outbound call to follow your outbound routes and obey CID, recording settings, trunk failover, etc. you want to use the dialplan using a string like:

local/[email protected]

Then you don’t need to worry about truck tech at all.

1 Like

… and to close the loop completely, you should set up your outbound route and trunk so that the call is handled specifically by that trunk if you have a need for that.

On my system, I have to specify that all calls to my cell phone that get FMFM’ed go out on a specific trunk and that’s how I handle it.

Thanks for the replies…

I need to send the call out through a specific trunk. I did that before with the “SIP/Flowroute/###” designation. How can I do that using the “local” option mentioned and/or with outbound routing?

The specified trunk should only be used in the case where the cell phone is called via an internal extension designation (ie 700), but there shouldn’t be any preference if the cell phone is dialed using it’s normal pots number (ie 1-xxx-yyy-zzzz).

It seems like I’m missing something basic here… surely it doesn’t require a rework of my entire configuration just because the trunk changed from SIP to PJSIP.

The equivalent to
SIP/Flowroute/15558675309
is
PJSIP/[email protected]
though you might not get Jenny because of needing a tech prefix, outbound caller ID issues, etc.

But I agree with @lgaetz that this is the wrong way to do it. Instead of a custom extension, try a virtual extension that uses call forwarding or follow me to call the mobile. If you need to force the call to use only or prioritize Flowroute, forward to e.g. 05558675309 . Set up an Outbound Route with prefix: 0, prepend: 1, match pattern: NXXNXXXXXX and a trunk list that has Flowroute as the first or only entry.

Thanks “PJSIP/[email protected]” is the answer I was looking for.

I’ll investigate switching to a virtual extension as time allows, but right now I’m just trying to get things working after the switch to PJSIP. It changed more than I would have expected.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.