Cronmanager encountered 1 Errors

Hi
I’m running FreePBX 13.0.195.18 with Asterisk 13.23.1. I’m seeing this error on several machines I run after doing the latest round of module updates. I also ran Yum Update from the CLI to update Asterisk from 13.19.1 to 13.23.1. I’m not seeing any issues on the PBXs or getting any complaints. When I run this command from the CLI “/var/lib/asterisk/bin/module_admin listonline > /dev/null 2>&1” , it runs with no errors. Anybody know if this is something I need to worry about?

Thanks

The following commands failed with the listed error
/var/lib/asterisk/bin/module_admin listonline > /dev/null 2>&1 (1)

1 Like

Same issue here on FreePBX 14.0.4.1 after doing the same updates.

Is there a simple solution?

Thanks

From the console, try running the command without suppressing all of the output (including the error output)

With the command run “as is”, the regular output and the error output (standard output channels 1 and 2) are both suppressed. In Unix, a command will always return a run status, but it may not announce any errors, since errors are normally reported on standard output channel 2 (The “2>” part).

The construct that causes this is “> /dev/null …” which sends all regular channel 1 output to the digital trash and “… 2>&1”, which sends standard error (std output channel 2) to channel 1.

The command to test with is

/var/lib/asterisk/bin/module_admin listonline

This way, you should be able to see the error that is triggering the non-zero return code that crond is reporting.

Thanks for your reply.
Now I’m getting the error:

[[email protected] ~]# /var/lib/asterisk/bin/module_admin listonline
no repos specified, using: [standard,extended,commercial,unsupported] from last GUI settings

Whoops\Exception\ErrorException: Comments starting with ‘#’ are deprecated in Unknown on line 23 in file /var/www/html/admin/libraries/BMO/GPG.class.php on line 613
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/libraries/BMO/GPG.class.php:613
  2. Whoops\Run->handleError() :0
  3. parse_ini_string() /var/www/html/admin/libraries/BMO/GPG.class.php:613
  4. FreePBX\GPG->checkSig() /var/www/html/admin/libraries/BMO/GPG.class.php:174
  5. FreePBX\GPG->verifyModule() /var/www/html/admin/libraries/modulefunctions.class.php:3266
  6. module_functions->updateSignature() /var/www/html/admin/libraries/modulefunctions.class.php:3172
  7. module_functions->getAllSignatures() /var/lib/asterisk/bin/module_admin:571
  8. showList() /var/lib/asterisk/bin/module_admin:862

I see that it looks like something is commented out in a file, but it’s called “Unknown”. Any ideas how to fix this? This is on one of my FreePBX13.0.195.17. I’m seeing similar error on one of my FreePBX 14 servers. Any input is greatly appreciated.

Log into the system console.
vi that file.
Use the command “:613” (colon six one three)

That will drop you onto line 613 in the source code file. Look at the code and see what file it was opening. Open that file with ‘vi’ and use the colon command again to go to line 23. See if that line starts with a “#”.

At least, that’s how I’d start.

Thanks again for your help. With your replys I was able to find another thread that is the same problem. It looks like when you update a server from 12 to 13, there are 2 modules that don’t update and they cause a problem with the latest round of updates. “Bulk DIDs 2.11.1.4” and “Bulk Extensions 2.11.0.7” . I just removed them and I’m waiting to see if the error comes back.

1 Like

other thread

Bulk DID and Bulk Extensions were EOL in version 12. 13 and newer use the new bulk handler so you should remove those modukes from your system.

Will do , Thanks Tony

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.