Cron job error

[email protected]:~# fwconsole job --run
Running dashboard::scheduler...Done
Running calendar::sync...Starting Calendar Sync...
Finished
Done
Running timeconditions::schedtc...proc_open(/tmp/cron.error): failed to open stream: Permission denied
[email protected]:~# fwconsole reload
Reload Started

In Cron.class.php line 281:

  proc_open(/tmp/cron.error): failed to open stream: Permission denied


reload [--json] [--dry-run] [--skip-registry-checks] [--dont-reload-asterisk]

Try running

fwconsole chown
[email protected]:~# fwconsole chown
Taking too long? Customize the chown command, See http://wiki.freepbx.org/display/FOP/FreePBX+Chown+Conf
Setting Permissions...
Setting base permissions...Done in 3 seconds
Setting specific permissions...
 10996 [============================]
Finished setting permissions

Same errors if I run fwconsole reload after :confused:

Any other debug info I can provide?

chown doesnā€™t touch /tmp

Try rm -f /tmp/cron.error the file will regenerate.

any chance it runs differently as the user asterisk as opposed to root ?

That seems to have resolved it!

rm -f cron.error, then fwconsole chown, then fwconsole reload outputs like normal. I ran fwconsole reload to make sure

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.