CRM module get Salesforce token -> Class 'Requests' not found

I’m trying to set up API access and keep getting this error when I click on Get SalesforceToken. Modules were all upgraded to the latest just yesterday. The Signature Status in the module admin says Good. HTTPS is configured. I tried shutting off the firewall to see if this was some service that’s being rejected. I tried opening the php file in question with no luck. (/var/www/html/admin/modules/sangomacrm/includes/sangoma/salesforce/src/Oauth.php )

The only other place I can find this error by Googling is a thread here where someone was having a problem installing the module.

Whats wrong here?

Customer Relationship Management Link

This is a demo account in salesforce in case that makes a difference. I assume I filled out the settings page in the CRM Module Settings correctly

Upgrade CRM from edge:

fwconsole ma --edge upgrade sangomacrm

Derp, it does mention several browsers, I should have thought to try in Chrome. Running that command and then retrying from Edge seemed to fix it. Thanks.

1 Like