Critical Error retrieve_conf failed, config not applied

Greeting to All,

I have just installed AsteriskNOW 1.50 but it’s not loading. I’m getting two errors when connected via http:/192.168.2.1/admin.

  1. Reload failed because retrieve_conf encountered an error: 1
  2. Failed to connect to the Asterisk manager through port: 5058

There is another error that keeps popping up on

INIT: Id “x” respawning too fast: disabled for 5 min.

uname -a reveals:

linux asterisk 2.6.18-128.1.1e15 # SMP WED Mar 25 18;14;28 EDT x86_64 x86-64 x86-64 GNU/Linux

I did the install after downloading the ISO from AsteriskNOW (ver 1.50 64) It appeared to install without errors until the system restarts, it then displays:

INIT: Id “x” respawning too fast: disabled for 5 min.

I’ve found this thread: I followed the instructions and it’s not working.

On February 13th, 2008 m4him7 (tadpole) said:

/var/lib/asterisk/bin/retrieve_conf
/var/www/pbx/admin/modules/framework/bin/retrieve_conf

the one in /var/lib/asterisk/bin did not have the execute bit set in it’s permissions (i.e., 644 vs 755)

The permissions to /var/lib/asterisk/bin/retrieve_conf are correct.

The directory: /var/www/pbx/admin/modules/framework/bin/retrieve_conf does not exist on my system. Is this a required location?

What could be wrong with my system? Your help is greatly appreciated.

Thank you

Not sure where that 5058 SIP is port 5060.

Can you get to the unit using PuTTy on port 22?

Good Morning and thanks for your response.

I’m able to ssh(don’t have Putty) to Asterisk. I ran a netstat and did not see a 5060 nor 5058. So are these port required to be opened or set in the Astersik box or on my router?

I was under the impression that the installation would set all parameters. Please advice.

Thanks again,

Ramon

~snip~
Using default FreePBX admin security alone will not protect your system from a web attack and may compromise root access to your entire server, if you do not change the password, before connecting the PBX to the Internet. For this reason, we recommend that you log in as root and immediately run passwd-master. This establishes Apache .htaccess security on your FreePBX web interface. After running this conversion utility, you can only log into the FreePBX admin interface with the username maint and the password which you establish when you run the utility.

To change the main passwords, run passwd-master from the command line.
This does the following

  1. Changes FreePBX to authtype = none in amportal.conf,
  2. Sets up .htaccess on the admin directory which contains FreePBX
  3. Sets the wwwadmin, and MeetMe passwords to the same one as maint.
    After running the command, to access all areas including FreePBX, the username is maint with the password of whatever you set during the passwd-master script. Maint gets you to admin (FreePBX) maint, FOP, MeetMe.

would expect the correct ports to be open, too, but what about the PC that you are using to browse to the FreePBX GUI? Is there a firewall active on it?

Thanks for the great comments/instructions.

I will make these changes promptly when I get back to work. Regarding the PC I connect with it’s a Mac I’m not sure that it has an active firewall on it. Will have to check.

Kind Regards,

Ramon

Question, in what directory should I be to run this command? I run the command from "/"
and I get

[[email protected] /]# passwd-master
-bash: passwd-master: command not found

Thanks

I suspect that the OP either misread or mistyped; either way, I suspect that s/he means 5038.

I have similar problems: port 5038 is not open on my Asterisk server. Running “netstat -na” lists various other ports open (including 80, 22, 111) but not 5038 (or 5060, but I suspect that, if I can do whatever it takes to get 5038 open, 5060 will open at about the same time), so it is an issue on the asterisk server box, not a firewall issue. Whatever application should open port 5038 simply isn’t running, or isn’t running properly.

passwd-master doesn’t exist on my system either: “find / -name passwd-master” gives no result.

It seems to be a common problem as a result of installing Asterisk server 1.5 from the current ISO.

My mistake, its port 5038.

That is odd. I am fairly certain it can be run from the root. Are you logged on as root?

Try find / -name passwd-master

Mine is in /usr/local/sbin/

I agree with you, its odd. I’m root when I go to /usr/local/sbin all I see is '." and '…".

Thanks again,

Ramon

What version of FreePBX?

I inherited my system from marketing so I never had the opportunity to do the initial downloads. Someone else will have to help. But you don’t have files that you should. Either something was not downloaded or not unzipped.

Since I seem to have much the same problem…

Mine was installed from the AsteriskNOW ISO image AsteriskNOW-1.5.0-i386-1of1.iso

I’ve just been laboriously through the ISO looking for a file whose name includes “passwd-”, including unpacking all the .rpm, .tar.gz and .cpio files. I can’t find any passwd-master file. I’m reasonably confident, then, that it couldn’t have come from the AsteriskNOW 1.5 installation CD - unless it’s programmatically generated post installation, which seems unlikely.

OK, if it’s not on the installation CD, should it be downloaded as part of a later stage of installation? (Does that happen?)

Or is it simply an omission from the AsteriskNOW installation CD?

And my /usr/local/sbin directory is empty, too.

I downloaded the AsteriskNOW-1.5.0-x86_64-1of1.iso. It’s interesting how the installs are missing the same files.

I’m not an expert on this so I’ll have to wait on the higher powers to be, *******s

Thanks for all your inputs!

Ramon

Since the installation and while waiting I have updated FreePBX to the following:

Core 2.6.0.0 enabled
Feature Code Admin 2.6.0.0 enabled
FreePBX Framework 2.6.0.0 enabled
System Dashboard 2.6.0.1 enabled
Voicemail 2.6.0.2 enabled
Info Services 2.6.0.0 enabled
Music on Hold 2.6.0.1 enabled
Recordings 3.3.9.3 enabled
Custom Applications 2.6.0.1 enabled

Hmmm… I wonder if that comes from PiaF (PBX in a Flash) PiaF uses FreePBX as the GUI for Asterisk, Webmin as the GUI for the OS, and Fail2Ban is preconfigured, all you need to do is simply download, install, update and configure.

But then there is this:

http://www.freepbx.org/support/documentation/installation/install-process-for-centos-5-1

I just installed Asterisk from AsteriskNOW-1.5.0-i386-1of1.iso and I ignored the 2 problems which are exactly matching with ones at the top of the page;

  1. Reload failed because retrieve_conf encountered an error: 1
  2. Failed to connect to the Asterisk manager through port: 5038

You can see the default opening page of freepbx sreenshot;
http://img101.imageshack.us/img101/8822/screenwn.jpg

Then, added the sip extension and configured the ekiga(softphone) to connect asterisk server. At the end of the day I was not able to interact ekiga phone with my asterisk server. Then I tired to check my configuration via CLI of asterisk but I could not see the sip command. I think there is more than one problem with AsteriskNOW-1.5.0 iso.When I added sip.conf to /etc/asterisk directory and restart asterisk, sip command appeared in the asterisk CLI.

Most of the people says this problem dissapear when you upgrade/update. What Do I need to update/upgrade and How can I do this ?

Thanks in advance …

Do an amportal stop followed by an amportal start.
That should solve your issue.
sip.conf should be a linked file from /var/www/html/admin/modules/core/etc/sip.conf

Happy New Year to All.

I tried the amportal stop and amportal start. It does start astersik and FOP but I’m still getting errors on the status page.

I ran the upgrade from the GUI still a no go.

Thanks

Ramon

I’ve progressed pretty far from my bumbling days of how do I wire this punchdown block. I’m not doing anything too fancy, but I have teliax, X-Lite, and an Aastra 57i working through asterisk.

All I need to do is figure out how to fix feedback only I receive when talking on the Aastra (the other end says icnd the quality is fine, no feedback) and I’ll be ready to dump the Avaya system.

I guess I don’t quite have ODBC support working with asterisk, but if I never get that working it won’t be the end of the world.