Creating my own CIDLookup

Can anybody tell me what is wrong with these settings?

The file I have created looks up a telephone number and echoes the outcome. I guess this can be incorrect, but the file doesn’t even seems to be called. Is there a way to check this?

There is nowhere near enough information here.

If you curl the URL


what comes back… should be plain text

Is does return plain text. I have added the PHP plain text header just to make sure, but without result. I even moved the file to an http server, to make sure the ssl certificate couldn’t be the problem.

Any ideas?

your host should be just the host, you have https in there. Its building the url off the various fields. Having https:// in the host field means its appending https from the server type to the https in your host to make https://https://host.domain

I have also tried that, with both http and https.

What nsimpson is saying is:

$url = sprintf('%s://%s%s/%s%s', $item['sourcetype'],$auth, $host, $path, $query);

so you don’t add http or https this is set by source type

I understood, and like I said I have tested with and without http:// and both didn’t work. Just to make sure I have also tested my DNS to be certain the server can be reached. Curl directly on the PBX also returns what I would expect.

I have also tried “CID Superfecta” by the way, this also didn’t work.

Fine. For your future tests, make sure you’re leaving http off as that will for sure to keep it failing. There’s something else that still isn’t working right. Could you update your screen shots with how you have it now?

Currently it looks like this:

Lets fill in the port with 443 (if that’s the port your https is running on) and see what that does.

good call this may be a bug… if port is blank we use 80, it doesn’t account for https

also if you look at the asterisk cli that may give you some insight as this all happens in dialplan

No change when using the port field. What exactly do I have to do with the Asterisk CLI?