Creating extensions with Freepbx

I’m new to Freepbx/Asterisk, and I have a question regarding the creation of extensions in Freepbx. I am using FreePBX 2.10.0.0 and Asterisk 1.8. I was under the impression that the Freepbx GUI was able to handle everything Asterisk related, including the creation of extensions. I have created an extension using the GUI, which then outputs the information in the “sip_additional.conf” as follows (mind you, I did not edit this file manually, I used the GUI):

[1000]
deny=0.0.0.0/0.0.0.0
secret=test123
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
trustrpid=yes
sendrpid=no
type=friend
nat=yes
port=5060
qualify=yes
qualifyfreq=60
transport=udp
encryption=no
callgroup=
pickupgroup=
dial=SIP/1000
[email protected]
permit=0.0.0.0/0.0.0.0
callerid=device <1000>
callcounter=yes
faxdetect=no

Now the problem is that I cannot register any softphone (using X-lite 4) to my Freepbx server on 192.168.30.161 when using only the GUI.

My softphone config is set up like this:

User ID: 1000
Domain: 192.168.30.161
Password: test123
Display Name: 1000
Authorization name: 1000

It is also set to Register with the domain and receive calls.

This does not work. On the other hand it does work if I input the exact same information in the “sip.conf” file, or if I include (#include) an external file “sip_custom.conf” and add the information manually in there.

So my question is, is this how Freepbx is supposed to work, by manually editing files? If it is not, than I would appreciate it if anyone could point out what I’m doing wrong, because the same applies for the SIP trunk too.

You don’t need the username parameter, you have something else wrong.

Is the softphone registering? Are you getting any errors in the log?

What kind of softphone is this?

We have hundreds of thousands of systems in use worldwide with millions of extensions (we really should put up a cool stats page) and have never seen this request.

Usernames are required when the username is different from the peer ID.

Yes, it was my mistake, I realized after I posted that the username is not necessary. I’m sure you read the post before I updated it. Nonetheless this line should clear things up:

“On the other hand it does work if I input the exact same information in the “sip.conf” file, or if I include (#include) an external file “sip_custom.conf” and add the information manually in there.”

Exact same information, as in, without the username. The softphone is not registering when I do not add the information manually in “sip.conf” or “sip_custom.conf”. I’m using X-lite 4. CLI shows the error:

chan_sip.c:24969 handle_request_register: Registration from ‘sip:[email protected]’ failed for ‘192.168.30.121:25826’ - No matching peer found

That makes no sense.

Look in sip.conf and make sure that the #sip_additional.conf is in the file, this is to include that file.

Also do a sip show peers from Asterisk and see if it is showing up.

Yes, that worked. For some reason I assumed that Freepbx would automatically include the additional files. On another subject, is it normal for the SIP trunk to appear as a peer?

When I do “sip show registry” I get “0 registrations”, but the trunk does appear in “sip show peers”.

Freepbx does include the files in the config. Did you modify sip.conf or install any asterisk files?

The only modification I made to “sip.conf” was to add an include pointing to another “sip_custom.conf”. I am not using a FreePBX Distro, I compiled it with the tarball, the same with Asterisk.

I’ve never had any problem with FreePBX creating extensions over the 7 or so years I’ve been using it and its predecessors. That being said, I’ve done all of my installs with “sanctioned” distros.

You say: " I’m new to Freepbx/Asterisk…". Yet you are trying to install this from the tarballs. While this is successfully done every day, there are still a lot of things that can go wrong. I’d strongly suggest that you get your feet wet with a “sanctioned” distro to get the feel of it and see how it is supposed to work. You can do this either on a dedicated machine, or using VMware to run it in a virtual machine.

BF

I am using VMWare. The reason I’m using the tarball install is because I need to use Debian, and as far as I know, the Freepbx Distros are based on Centos, which is not what I am using, nor plan on using.

@W5WAF: I don’t know if you read my last comment, but the extension issue is fixed. I have other questions but I think it would be best to create a new post.

I ma facing same problem. I am using Certified asterisk 11.2, freepbx 2.11 and Xlite as soft phone.

My sip_additional.conf is like:

[1001]
deny=0.0.0.0/0.0.0.0
secret=asd123
dtmfmode=rfc2833
canreinvite=no
context=from-internal
host=dynamic
trustrpid=yes
sendrpid=no
type=friend
nat=no
port=5060
qualify=yes
qualifyfreq=60
transport=udp
encryption=no
callgroup=
pickupgroup=
dial=SIP/1001
[email protected]
permit=0.0.0.0/0.0.0.0
callerid=1001 <1001>
callcounter=yes
faxdetect=no

And when i used following details for registering Xlite.

Display name:1001
Username:1001
Password:asd123
Domain:192.168.1.75

And I set ‘Send outbond via’ as ‘domain’.

And while registering with Xlite i am getting an error “Registration Error 403. Forbidden”.

And in asterisk server CLI I fouund an error like " NOTICE[2361]: chan_sip.c:27749 handle_request_register: Registration from ‘"1001"sip:[email protected]’ failed for ‘192.168.1.25:10512’ - Wrong password"

My asterisk server is installed on Centos 6.4, and centos is running in VMware.

Can you please find a solution?

nbstk13 did you find a solution to this problem. I am having the same issue. Thanks!

yeah, just add extension.conf file manually. Thats all :slight_smile: