Could not reload FOP server using the

Another after install issue that I am facing.

After a fresh install on CentOS 5.1, things seem to be working fine except for OP Panel. I have a yellow warning next to my OP panel server status.

I also have the following message on the main page

“Could not reload the FOP operator panel server using the script. Configuration changes may not be reflected in the panel display.
Added 52 minutes ago

Any ideas what has went wrong and how to fix?


the script is located at /var/lib/asterisk/bin. It is a very simple script that runs one command. It attempts to do a killall on the script. it failed for some strange reason. run the script again or lookup the PID and force the process to terminate.

FYI: The error will stay in the status list until you delete the error.

can anybody help me ?
i have built asterisk from fedora core . i having a problem in FreePbx interface, this problem is when i
use reboot command and after reboot command finished and then op panel was warn , it is present warn yellow

I have just installed Ast 1.6 and FreePBX 2.5.1 on Fedora Core 10. I had the same issue and did a few things:
CHECK OWNERSHIP - I had a lot of errors with permission denied in it. If you’re running Asterisk as the user and group asterisk:

  1. Make sure that httpd is running as user and group asterisk (not group root!)
  2. If needed, check that Asterisk is being run as asterisk (not that related, but couldn’t hurt).
  3. Run chown -R asterisk:asterisk on these directories:

Next (and the big finish) - check your asterisk.conf in /etc/asterisk and /usr/src/freepbx-(VERSION) or whatever source dir you’re using. Somehow, my ASTRUNDIR was set to /var/run instead of /var/run/asterisk. Make sure that it’s set to /var/run/asterisk, that /var/run/asterisk exists, and that it’s owned by asterisk:asterisk. That should work.

Once all of that is done, re-install FreePBX using /usr/src/freepbx-(VER)/ followed by /usr/src/freepbx-(VER)/install_amp. Once it’s installed, everything seems to work.

TO TEST this, open a sudo’d terminal, type in amportal. You’ll either get a usage message, which means that it’s working, OR an error message. If the error message says that your Asterisk run dir is set to /var/run instead of /var/run/asterisk, you didn’t finish re-installing FreePBX using ./install_amp.

Note: FreePBX does seem to work with a few tweaks with Ast 1.6 and FC10. The tweaks are just permissions and creating standard directories that somehow were missed. I may add an article this week about installing Ast 1.6, FreePBX 2.5.1 on FC10 to my blog -

I’m working on the new T.38 fax rx and tx now. Check the blog after 4/10/2009 to see if it worked…

Good luck!



The FOP is actually a separate project that gets included with FreePBX. As of my writing of this statement there has not been a formal release of the FOP to support asterisk 1.6 yet. The last release .29 was on June 12, 2008, there was some pre-alpha testing code for asterisk 1.6 was being worked on in November of 08 if you do a good search of that site ( but nothing has been released yet.

Several other things you mention are also changes that asterisk has done not mistakes or bugs of FreePBX. The change of /var/run to /var/run/asterisk is a change in the code of asterisk 1.6 from all previous versions.

/var/www/html/* and all sub-directories under it should have the ownership set to asterisk:asterisk as Apache should be running as the user asterisk also if you have followed the installation directions.