FreePBX | Register | Issues | Wiki | Portal | Support

Could not reload FOP server - message



I am getting this “Could not reload FOP server” message with the following details - Could not reload the FOP operator panel server using the script. Configuration changes may not be reflected in the panel display.
Added 1 hour, 5 minutes ago

I looked at the ticket for closed bugs #2217 and this did not fix the issue. Any other ideas?


Chuck Bunn



I’m having the same issue and like you, I looked at the closed bug but the solution didn’t apply. I installed in a bit of a round about way so I imagine my problem is a configuration issue associated with that process.

I started with a VERY basic Centos 5 install. Got the * and FreePBX sources from the EASYVOXBOX distro. Then edited their install script to ignore the stuff specific to EVB. There were a couple of minor hiccups but got everything working except FOP. The warning message I get is basically “can’t reload FOP server with”. Funny thing is I can logon to the machine as root and start the server. The status will then show green but I still can’t access the panel. If you come up with a solution, please share it here and if anyone else has a suggestion then I am ALL ears (well eyes really).



I have everything working including FOP, I just get this message in the system status window. So I assume its a bogus message, it just annoying to have it keep poping up.



I got FOP running without error messages by renaming the file in:

to eg

then restarting asterisk

Michael Daly



I did some checking and when looking into the amportal.conf file the AMPWEBADDRESS value was being set to AMPWEBADDRESS=xx.xx.xx.xx and I after looking at another system that worked there was no xx.xx.xx.xx. it was only AMPWEBADDRESS=
so after removing the xx.xx.xx.xx
The server was able to resolve the IP to the localhost and everything worked.


I installed asterisk now fresh on 1-12-09 I checked both i don’t have an
and on my amportal.conf the AMPWEBADDRESS= is blank, and still get the problem is it a bug?


more details please… Which version of asterisk and FreePBX? Last I checked the FOP does not work with any version of asterisk 1.6 yet.


I just installed a week ago and installed all modules


That is only half of the information needed. The version of asterisk you are attempting to use?


my asterisk version is the 1.4.22


Well the FOP should work.

Now it comes down to more questions and you providing answers.

Is your system build from a distro? If so who’s? If not it’s hand built, so what OS, who’s directions did you use (link please), what did you deviate from in the directions and why.

fyi: my bounce script is at /var/lib/asterisk/bin/


it is the asterisk now bistro that comes with centos 5.2, the I just downloaded it 2 weeks ago and burned the iso image and installed for testing.Also I installed all freepbx moduels available


So that you know asterisknow is in Beta but it has been pretty stable, have you checked the AsteriskNow bug repoting system for this issue to see if they know about it already, and/or posted a fix for it? If not please report it to them as they might have a minor install issue.


Thanks for the newa, I did check



I have posted this as a bug…



Please post this as a bug in the AsteriskNow bug tracker.


please change manage_user : and manage_secret : of /var/www/html/panel/op_server.cfg to asterisks /etc/asterisk/manager.conf admin and secret. Then RESTART the machine which reload on port 4445


Could you clearify your message a bit more? I’m in the file “op_server.cfg” and see:

; user and secret connting to * manager

Are you saying to change the “UNUSED” to “asterisks /etc/asterisk/manager.conf”?


Please pardon my need for detail. I’m rather new to this.


yo solucione el problema utilizando el comando

amportal restart

luego funciono todo…