Correct dial pattern for Bandwith trunk


Current Asterisk Version: 18.19.0

I am using Bandwidth for the first time and running into a little difficulty with the outbound route dial pattern.

Inbound is working fine.

I have seen a few articles, but many are old and haven’t produced much help.

I have read in the articles to:

Put a “+” No quotes in the prepend field of all patterns
leave the prefix blank and paste “1NXXNXXXXXX” in the “match pattern” field.

That didn’t work.

Anyone out there use Bandwidth and freePBX?

I am just looking for general use dial pattern.

According to user guides, in the North American Numbering Plan area, they accept 10 or 11 digits as in NXXNXXXXXX or 1NXXNXXXXXX. For international calling, they require the ‘+’, country code and number. The leading +1NXXNXXXXXX may also be allowable for calling within the NANP. If this is not working for you, double-check your outbound route patterns in FreePBX or contact the carrier’s support group since carrier documentation is not always current.


A user in this thread says they had to contact to allow 10-digit dialing. It is quite possible that they have not properly set up your account for outbound calling patterns you expect.

Thank you for your response. This is the first time using Bandwidth and I am able to receive calls into the PBX.

I use VI and Flowroute also and have had no issues with dial patterns and outbound routes. Honestly, I am not 100% sure if the outbound route is the problem at this point as I am seeing:

app_dial.c:2719 dial_exec_full: Unable to create channel of type ‘PJSIP’ (cause 3 - No route to destination)

As this is my first trunk config for Bandwidth, here is the config:

Really… Tha’ts it. It’s IP based authentication so no credentials.

Outbound dial patterns:

Two things to look at. First, is there a dial plan conflict with extensions and you 7-digit dial pattern and one I suspect is not the case but will mention: Did you put the Bandwidth trunks in the first page of your outbound route pattern? When it says no route to the pjsip trunk, that is pretty straight forward as to the fact it is unable to route through the PBX to the trunk.

Have you tried calling a 1+10 digit number to see if that works. Also, your 7-digit dialing will probably interfere with your 10-digit dialing where you prepend the 1. You need to have either 7-digit dialing and 1+10 digit dialing or 10-digit and 1+10 digit dialing to avoid dial plan confusion. Too many local exchanges in an area code will conflict with actual area codes.

By your area code 208, I see you are in Idaho. If you were do dial a 7-digit number of 478-1234, you would have to press ‘#’ at the end because 478 is also an area code and the dial plan would be waiting for 3 more digits unless your press ‘#.’. This is not a good practice and can be confusing to the user and the network. I recommend that your remove 10-digit dialing where it prepends the 1.

You haven’t mentioned what type of phones you are using. The phones themselves can have dial plans that might be sending something to the system that is not caught correctly by the routes.

Watch the console as a call is made and see exactly what number is passed from the phone to the PBX.

Hello and thank you.

So, I believe yes:

Trunk sequence is using the only trunk (route) available.

I have altered the dial patterns per your suggestion. I am only using one at this point for testing:

The phones are EndPoint Manager provisioned Yealink T53’s.

It’s crazy… I have many deployments with VI and Flowroute and this has never been an issue. It’s something to do with Bandwidth and the config I am using. Dial patterns have caused issues in the past, but I was able to alter them and get it working.

After the changes I am not getting “All circuits busy” Now I am getting "your call cannot be completed as dialed, please check the number and dial again…

If I dial using a 1 I still get the “all circuits busy now”

Ticket open with Bandwidth and they state “I don’t see you sending this call to our IPs. I only see that you are sending SIP options to our IPs (No. 1535 and 1543). Please ensure that you are sending calls to our IPs.”

This causes me to raise an eyebrow also:

Dial plans

Bandwidth supports E.164 for outbound calling only and is the default dial plan for our SIP Trunking Product. E.164 is an internationally recognized standard characterized by a “+” followed by the country code, then the phone number. For example:

Local & Long Distance: +19192971000

Just for giggles… I set up a Voip Innovation trunk… It worked perfectly, the first time.

I’m out of ideas. Unless there is just something wrong with the trunk setup but I don’t see anything obvious.

Thank you for taking a look! I appreciate it. It is a bit baffling.

We have Bandwidth as well and we are using just the regular default dialing plans in freepbx and it’s working fine without issue.

I suggest opening a ticket with Bandwidth and they can inspect your SIP traffic and let you know what needs tweaking.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.