Copy trunk data

Hi, I have an “old” Freepbx box where I am admin. Its Freepbx, Asterisk (I do not have root access.)

Now I have set up a new distro with Freepbx and Asterisk

I have set up (copy and pasted) over the extensions, outbound routes, trunks, inbound routes etc.

When I take the old system from the network and set the new system to the “old” IP the extensions work fine.

However, the trunk stays down and I get an error message trying to place an outgoing call. Also no calls come in.

I am 100% sure that I have correctly copied all the trunk information including “PEER Details” and “USER Context”.

Any idea on what to do to debug this?



Did you set the SIP general settings that may not have been present in an older version (was in sip_nat.conf)

Also are you using same IP and firewall?

Did you copy registration string if required?

Look in /etc/asterisk/sip_additional.conf on the old and new systems and compare the peers.

Thanks for your answer. The trunk is IAX2.

Yes, I am using the same IP. Once I put the old system on again, it worked right away.

No change on the firewall.

How can I look into /etc/asterisk/sip_additional.conf from the FreeBBX client?

You can’t look at it from the web interface. It will be in iax_additional.conf anyway. You could use the java SSH client to get a console, or the Putty client is what we suggest you use.

You sure the new machine doesn’t have connectivity issues on WAN?

I have no access to the CentOS on the old machine, only to the new one. I have only access to the FrewPBX on the old one. So I believe that SSH will not work.

As the extensions connect without a problem and I did not change the firewall I am sure that the network is fine. While I am new to Linux, I am a network pro since many years.

Ok, you can login to SSH on the current machine, from the Asterisk console start and IAX debug and see what is going on.

It is useful to turn off dial plan debug in this case witn ‘core set verbose 0’ so that you are not cluttered with extraneous data. I would also enlarge your buffer on the SSH client.


So, I have an old system that is up an running. I have no root access and I am not allowed to change anything including the password. (I know hiw this would be done).

I have a new system that I have full access to. I tried to move all the settings over and to replace the old system with the new one.

But the trunk does not come up and I have no idea where to start looking.

Sorry that I am asking all these questions but I really don’t get it.

All I have to maintain the old FreePBX is a web-login called “Admin” and a PW for that.

That’s not the root password for the machine.

I have no other access.

Whn I started a SSH session, I found nothing that worked as a login.

If you use Google you can probably find some info on how to boot the old system into single user mode. Once in single user mode you can change the root password.

Post your trunk settings (redact anything that could identify you) and post an IAX debug log.

I have been working on this, but I have not been able to produce a IAX debug log.

I found an explanation here
but I don’t fully get it. The login worked.