Contacts for Sangoma Desktop Client

I have installed the Sangoma Desktop client just to try it out. I have a PBXact system with the following details.

PBX Version: 15.0.23
Asterisk Version: 16.8
Sangoma Desktop Client App: 3.4.0

I have installed all the required versions of modules for Sangoma Desktop Client as per this wiki

I can log into the application fine and I can call I also tested some features like call parking. But the problem I am having is regarding contacts.

I cannot see any contact in the Sangoma Desktop Client. If I search for contact then I see it but there is no list populated by default.

I have configured the contacts in Contact Manager and also added favorites just to test. Neither of them gets populated. I even logged into UCP and I can see the contacts as well as favorites. Even after adding it via UCP, I still don’t see it in the desktop app. What am I doing wrong here?

Just for the information, I have the Endpoint manager license which has phone apps included if it matters.

I believe the contacts are only exposed by using the 3-char search in the right-hand slide-out panel - That’s my experience anyway.

I haven’t setup any Favourites (the contact search is sufficient for me), however, I believe they should be listed by default once configured (How to Set Up Favorite Contacts - Sangoma Connect - Documentation).

Maybe I’ll try them out.

1 Like

When I configured the favorites I could see them in UCP but not in the app.

I’ve just setup a Favourites List & it’s appeared as a list of contacts in the right-hand slide-out panel of the app as expected.

The steps I took were as follows;

  1. Checked Favourites were enable in ‘Advanced Settings’.
  2. Created a Favourites List in ‘Contact Manager’ with just 4 entries.
  3. Linked that Favourites List to my USER account in ‘User Manager’. Had to save change & Apply Config.
  4. Signed Out/back In to Sangoma Phone Desktop App - Only then do the favourites appear.

Did you link your Favourites list to your USER account or a GROUP ?
Did you Sign Out/back into desktop App ?

I’ve noticed some behaviour in the App only changes when manually you sign out/back in to it. Closing & restarting the app doesn’t always seem to do it (& yes, even when fully quitting the app from system tray, not just closing from desktop, which doesn’t actually close it).

Lists of Favorites are created in Contact Management, and then need to be applied to the user (or group) in User Management. If you’ve already created one or more Favorites lists, then the missing step is probably to define which favorites are applied to the user:

I configured everything as per the steps and logged out and logged into the app manually but I still don’t see the contacts. I am attaching the screenshots below.

User Settings

Contact Manager

Advanced Settings

Sangoma App Screenshot

When I click on view, I just get a blank checkbox like this.
Sangoma2

I wonder if it could it be related to the App showing ‘Calls disabled - No Microphone Detected’ ?

Only a wild guess but MAYBE that status disables some other functions also (like the Favourites lookup).

I thought that too, but I tested it again with the microphone connected so that error is gone but still no contacts.

PS: When I try to log out and log back in it gives me a warning that “the SSL certificate is invalid, do you still want to proceed?” I am not sure it affects the functionality of the app.

Another stab in the dark, but I notice you have the Group ‘Desktop Client’ set to ‘show in contact manager groups’ & ‘viewable contact manager groups’ in your User management record.

I have nothing in those 1st two boxes for my setup, you could try removing those in case there’s some kind of conflict between what groups are viewable to that user & whether the favourites are in those.

Don’t forget to log out/in the app after saving the user changes & applying config.

PS. I believe the App uses secure communication to/from your PBX. The install wiki says FQDN is recommended but an IP address can be used if a self-signed certificate with the IP address as its common name is used during the HTTPS setup when enabling Secure Ports in Port Management. I personally use an FQDN with a Let’s Encrypt certificate to satisfy that requirement.

I tried removing the ‘contact manager groups’ & ‘viewable contact manager groups’ but no luck. Is there a log file showing whether it even looks for it or not?

I did try to find an event in several log files that might relate to Favourites being refreshed in the app, but could not find anything. That doesn’t necessarily mean there isn’t one, but if there is, I don’t know where to find it.

You mentioned the App complaining that your ‘SSL certificate is invalid’, but haven’t confirmed if/how you’re resolving the SSL requirement. This could be a source of the problem & I’d suggest meeting those requirements (as listed in the setup instructions) to rule that out.

I recreated the favorites and reinstalled the sangoma app, and it’s working. I am unsure what was wrong but I will dig to know the real reason. But, I have not yet fixed the SSL error. I will do that but I don’t think that it is related to the issue. I will just reply here If I find anything conclusive.

Glad you got it working.

I personally think this new App is pretty good, however, I have found a significant issue with the ‘Call log’ that has been acknowledged by Sangoma Support/Engineering, so I’m hoping they will fix that & I’d personally like some other features back that were not carried over from Zulu (ability to control/link to Desk Phone & ability to login to multiple PBXs/Extns simultaneously), but apart from that, I’m using it daily with PBXact.