Contact-URI


#1

Hi,

Hope someone can help. My SIP provider requires that the Contact Header in the SIP request contains our public IP address. at the moment it’s sending the local IP.


        Contact: <sip:01xxxxxxxx@192.168.10.21:5060>
             Contact-URI: sip:01xxxxxxxx@192.168.10.21:5060
             Contact-URI Host Part: 192.168.10.21

I need it to send:


        Contact: <sip:01xxxxxxxx@<my external IP>:5060>
             Contact-URI: sip:01xxxxxxxx@<my external IP>:5060
             Contact-URI Host Part: <my external IP>

In the PEER details i have tried the following:


host=<SIP PROV IP>
type=friend
insecure=very
externip=<my external IP>
bindaddr=<my external IP>
realm=<my external IP>
domain=<my external IP>
fromdomain=<my external IP>

However it still displays the PBX’s internal IP in the SIP Headers.

Any ideas on a possible solution to this problem?

Thanks,

Jimmy


#2

I am having a similar issue did you manage to get this resolved?


#3

Hi,

Yes, in tools>Asterisk SIP settings, configure external IP and NAT yes


#4

Hi,

saying that I had the same problem. And I did turn SIP settings on and all looks fine, however I am still not getting Caller ID on outgoing calls and only one way audio. Spent 2 days now on this. I have another SIP where registration is used and only difference now I can see is that the registration SIP have no port attached to the contact-uri.
Anyone know where to disable it?

BTW can I ask who is your provider? Also if you could post you PEER details that would be great.

Many thanks


#5

Hi,

I also spoent a couple of days trying this out and a couple of hours on the phone top the provider. after many wireshark scans etc i found it to be our firewall. Are you using PfSense or Monowall per chance?


#6

This sounds like a NAT problem, especially if you are getting one way audio. Check those SIP settings again nat=yes and the ip is set to either dynamic or static, whichever you have, then let it autoconfigure. That should sort things out OK.


#7

Actually provider is Gamma Telecom. Got it working today. For voice it was my router doing funny things, so replaced that.
For CLI they have asked me to use RFC3325, but it would involve modification which is not as easy.
However I have tried something else. I have added Remote Party ID (sendrpid=yes, trustrpid=no) and that worked fine.
Job done!
Thanks


#8

I had to set the outbound nat to manual on our pfsense router and set up the manual rules too.


#9

Hi guys, I am also having issues getting my Gamma SIP trunks working correctly.

For my outbound peer settings I have used jimmyuk’s example above.

The details I have been given by Gamma are

  • UDP port 5060 egress/ingress to 88.215.61.195 (SIP signalling gateway).
  • All UDP ports between 6000 - 40000 egress/ingress to 88.215.61.196 (Media gateway). Omission of this setting will result in one-way speech

Currently I only have the outbound peer details as above everything else is blank in the trunk config.

I have set NAT to enabled in the SIP settings and entered the external IP and LAN subnet, I have also forwarded the relevant ports through the firewall.

Could someone with a working setup please let me know what details they are using for their trunk settings.

Thanks

Rob


#10

It maybe your router, I have a PfSense setup and i had to setup outbound nat rule to manual. asw soon as i did that it worked.