Contact URI showing sip:[email protected]

Hi All,

I am currently running FreePBX with Asterisk 1.8.32.1 installed and it has been working fine for quite some time but recently I noticed my inbound calls were failing.

Upon discussing with the service provider they indicated that the Contact URI is in an incorrect format. In the Registration message being sent to to the provider the header for the From and To addresses are fine in the format of sip:[email protected].

The Contact URI though in which they key on for delivery of calls is showing:

sip:[email protected]
Ex. sip:[email protected]

My trunk settings are (edited):

type=peer
port=5060
insecure=very
host=sipprovider.ca
disallow=all
context=from-pstn
allow=g729&ulaw
username=1234567890
secret=xxxxxxxx

Register String:
1234567890:[email protected]ipprovider.ca

Any idea why the “[email protected]” is showing up and how I can get rid of it / change it? I need to have the Contact URI in the format of [email protected]

My trunk settings are what I thought would correct it but I can’t seem to get it to work :frowning:

Thanks,
Darryl

Daryl
Do you have a Static or Dynamic Internet IP address at your office?

Is freepbx NAT’d (behind a firewall/router)

Check your Asterisk SIP settings

What do you have there? Make sure your external IP settings and Local Network settings are good

Hi Reilly,

Thanks for the quick reply!

I have a dynamic IP address in theory but it has not changed in 6 months :slight_smile: I have it set in the PBX as a static IP as it rarely will change. The FreePBX is behind a router… Regarding Asterisk SIP settings the External IP address is set correctly as well as the Local Network.

Thanks very much for the help - this is driving me nuts!

Darryl

What is the router model

It’s a DLink DIR-825, but running DD-WRT for the firmware version V24-SP2.

In regards to the router though I don’t believe this to be the problem. The main reason is when performing a packet trace on the inside of my network and looking at the initial register message coming from the FreePBX box the Contact URI already shows "[email protected]

Anything else I can check?

Thanks!

Daryl,
I was curious about the router to see if it was a SIP ALG issue, but with it being DD WRT i doubt it has any problems with SIP.

Try adding nat=yes to your sip trunk settings
Also check that nat is set to yes on Settings > Asterisk SIP Settings

Hi Reilly,

Thanks again - Asterisk SIP settings were set to NAT Yes already, and I did add it in to one of the sip trunks that is having the issue but still no change. On another note, I have another SIP trunk that is working and putting in the correct Contact URI but to a different provider.

Very strange…

I hate to ask but did you reboot after changing nat settings

Also have you checked out this forum post where the guy changed the registerstring.

He replaced the sip.phonecompany.com with the trunks context instead

Hi Reilly,

Thanks again for the info and yes definitely one of the first things I had done was reboot :slight_smile: (first step in troubleshooting 101 hehe - second step…reboot again!)

I’ll take a look at the other link provided and see what might help from that.

Best Regards,
Daryl

Hi,

I’m struggling with this same issue. However, my registration string is quite long and wondered if that can be an issue. It looks like the following.

123456789012345678901234567890:[email protected]/123456789012345678901234567890

If the length ok, then I am stuck with the same issue.

Jon

Hello!

Did you find a solution for this? I’m encountering the same problem. Rather than [email protected], my provider needs [email protected] instead of “s”.

Thanks!