FreePBX | Register | Issues | Wiki | Portal | Support

Connecting to Toshiba PBX - No out dialing


(christrati) #43

That would make sense that Toshiba requires an auth. That’s how I setup the trunk as well.

Curious if you got caller ID working ok. I do know there is an issue with transferring. In fact, there is still a PJSIP bug when doing a warm transfer, but hanging up early–making it like a blind transfer.


(Rich C) #44

Hello As promised for the benefit of anyone else having the misfortune of using a Switchvox please see how I got this working:

My goal all along has been to connect these two systems and get extension dialing working between them.

So First on the Toshiba:

ILG settings:
Create = 41 (this is user defined so pick any unused ILG number here)
01 Group Type: SIP
02 Line Type: Tie
03 Service Type: DIT
04 Private Service Type : Q-SIG
11 DID Digits: 3 (I have 3 digit dialing on the Toshiba system)

NOTE There are a ton of other default settings which were left alone.

OLG settings:
Create = 41
01 Group Type: SIP
02 Trunk Type: Tie/E&M
03 Service Type: Standard

NOTE There are a bunch of other settings there which I left as default.

Now it is time to edit/create the SIP Trunk:

SIP Trunk:
ID: (for this example mine was 3)
01 Equipment: <Cabinet number + slot number> In my example here I used a MIPU card so for my example I used 0302.
02 LAN interface number: 1
03 SIP Trunk Channels: 6 (This is the number of SIP Trunk Licenses you wish to use for this trunk. Important to note that this number will define the total number of concurrent calls which can take place as well - 1 call per license)

Service Def:
ID: (for this example mine was 1)
01 Registration Mode: None (other examples of those who have used FreePBX set this to client doing so in a Switchvox will cause SIP registration/connection errors)
02 ILG: 41 (same as above)
03 OLG: 41 (same as above)
04 Effective Channel Number: 6
05 Domain Name:
06 SIP Server:
35 SIP Trunk Message Option: SIP Server IP Address
36 SIP Trunk Message to Header OPtion: SIP Server IP Address
37 SIP Trunk Register Message From Header Option: IPU IP Address
38 SIP Trunk Register Message To Header Option: SIP Server IP Address (other option is FQDN) - I am not sure if this is configured properly

Service Assignment:
00 Channel Group: 3
02 Service Index: 1 (Same as above service def)

URI: (This is critical)

Every extension you wish to be able to dial from the Switchvox to the Toshiba must be listed here. There is a ~150 URI limit.

00 SIP URI Trunk Service Index: 1 (or another number you wish)
01 SIP URI Index: 1
02 SIP URI:
03 SIP URI Username: <must be the same as 02 above>
04 SIP URI password:
05 SIP URI Channel Group: 3 (same as above)
06 SIP URI Attribution: main
Then clicked add.

Other URI Entry:
01 SIP URI Index: 2 (and so on for every extension there after)
02 SIP URI:
03 SIP URI Username: blank
04 SIP URI password: blank
05 SIP URI Channel Group: 3
06 SIP URI Attribution: sub

NOTE The above needs to be an extension from the Toshiba system and cannot exist in the Switchvox.

Toshiba Flex access code:
00 Access Code: 87
01 Feature Name: Line group access code- one access code for each OLG
02 OLG Number: 41 (as entered above)

Now for the Siwtchvox Settings:

Enter in a New VOIP Provider:

In Provider Information:
Provider name and UID are best left to be the same
UID: same as 02 SIP URI for the MAIN above
PWD: same as 04 SIP URI password for the MAIN above
IP: of the MIPU card lets just call it (192.168.0.43)
Enter in a Main extension from the Switchvox (wont work without it)

Now under Peer Settings:
Select Peer
Apply Incoming Call Rules to Provider select Yes

Caller ID Settings:
leave Supports Changing Caller ID as no
Select Caller-ID method from header (I intend to test remote party ID but I know from header works)
I have If available, use PAID/RPID for incoming Caller ID set to Yes but I am not sure if it makes a difference.

Connection Settings:
SIP Port 5060
SIP Expiry (in seconds) 120
Authentication User <Same as UID from provider information)
Always Trust this Provider Yes
Use Local Address in From Header Yes
I also included my local Switchvox IP in SIP Provider Host List. (not sure if it is needed)

Call Settings:

ONLY select ULAW (default) to yes
The rest tick to Off.

Select Save SIP Provider.
Check Connection Status to ensure it says OK.

Outbound Call Rules:
for my office we use unique numbers for each office. So I was able to enter in the following rule:

Number begins with the digits 9
The rest of the number must be between 2 and 2 digits
Primary Call Through Provider
apply to all existing extensions

Save it.

Inbound Call Rule:

RANGE DID rule (again because each of our offices use “prefixes”
Start: 800
End: 899
Incoming Call Type Voice Calls
Incoming Provider
Apply to all existing extensions
Save it.

Your Done. So long as the URI is populated with (in this case) all extensions on the Toshiba starting with 9 then you can dial that extension from the Switchvox with no prefix. From the Toshiba you need to dial the Siwtchvox using prefix of 87+the 800’s extension number (using the example above)


(Rich C) #45

I have another test I will be running shortly. Right now I am only able to pass the UID of the Toshiba URI as the CID which is the same as the VOIP provider on the Toshiba. There is a setting I am going to try on the Switchvox called Remote-Party-ID. I am not sure what that will do if anything. I will try it shortly and see what happens. again for me because i have three different offices this is not as bad as it could be for others. So my CID would state Office 1, Office 2 and Office 3. Given that we are not talking 100’s of people at each location this is not a huge deal for us (obviously proper CID would be great…but hey).


(Rich C) #46

I have yet to find a way with the settings I have available via Switchvox to get caller ID. What is killing me at the moment is that I’ve setup my secondary site and the weirdest thing is happening. The 5060 SIP connection is not being sent out form the Toshiba to the FPBX/Switchvox. I am still able to call from the FPBX/Switchvox to the Toshiba but the connection/ response back is being routed from the Toshiba to my companies WAN IP…


(christrati) #47

I’m assuming the secondary site is connected via a VPN? Maybe the SIP packet is using the WAN IP when calling the Toshiba system. If this is a second site, you need to make sure you setup a second trunk, which means another outgoing/incoming group and setup the routing appropriately for those specific extensions.

For example, on my Toshiba setup, I would setup another incoming/outgoing line group and then create a new route in the StrataNet setup. I would then create extensions or range of extensions for that site and link them to that new route.

And callerID I never got to work correctly going outbound of the Toshiba. I could get inbound to work, but never outbound. It always showed the CallerID as what you use to login to the SIP trunk.