Connecting to FreePBX using different port than 5060 with VtechET605 phone

I am creating a PBX in the cloud and have configured FreePBX/Asterisk to bind the SIP port to 7222 (instead of 5060). I’ve configured my sip Trunks properly to register with this configuration. However when I try to connect a VTechET605 phone to this PBX on the port 7222, I am unable to register. I’m not an advanced user (and would like to learn, so if you have information that will help learn, this is better than just a simple answer :slight_smile:). When I attempt to register I get the following error on my Voip Phone:

Jan 7 13:40:42.619 [WARN ] SIP: transaction_timeout udp: 1000067 (32000)
Jan 7 13:40:42.619 [ERROR ] SIP: transport error: 1000067 → Udp:###.###.###.###:7222
Jan 7 13:40:42.619 [NOTICE] SIP: Add dirty host: Udp:###.###.###.###:7222 (0 sec)
Jan 7 13:40:42.620 [ERROR ] SIP: request 1000067 destination invalid Udp:###.###.###.###:7222 313634313834343434373334323531-micp1mk7s7pb
Jan 7 13:40:42.621 [NOTICE] SIP: final transport error: 1000067 → Udp:###.###.###.###:7222
Jan 7 13:40:42.621 [ERROR ] SIP: transport error 1000067: generating fake 599

ip = ###.###.###.###
I’ve looked everywhere for what exactly this means but without any success on finding any information about it. I have also checked the asterisk log file (it never sees the request for REGISTER in the logs nor does it log anything related to this specific connection). Being that there are no asterisk logs and I don’t think that these error codes are that helpful in solving the problem, I will post the configuration I am using for the phone.
Account: 3001
password: *************
Registrar: voip.fqdn.com #NOTE using my fqdn here
Outbound Proxy: voip.fqdn.com:7222

I’m stumped… I almost think that it has to be that I am using an Outbound Proxy with the fqdn and the error is saying that we can’t proxy off that port to register. With that being said I have also tried without the Outbound Proxy and instead used that address for the Registrar setting. Any help or informational articles you can send me are much appreciated.

Well this is embarrassing. The reason Asterisk wasn’t showing any attempt to login or anything was because my commercial (front facing) firewall wasn’t allowing traffic on port 7222 UDP it was allowing 7222 TCP… Registration successful when using fqdn.com:7222 Thanks for all who looked into this problem.