Connecting a Grandstream gxp1450 to an extension on freepbx 15.0.17.34


(United Kingdom) #1

I have created a chansip extension 212, using Quick Create Extension. I set the secret to a simple one for testing.

but all I get when I go to reports/ asterisk info is:-

my phone is a Grandstream GXP1450 and has been factory reset. I put

212 as the account name.

my freepbx ip as the SIP Server.

212 as SIP User ID and Authenticated ID.

the basic password in Authenticated Password.

and Shop in Name.

have I missed a step or something


(Lorne Gaetz) #2

You need to confirm the sip port to which the device registers. In the admin GUI, when you edit the extension, the port used is noted at the top. If the port is not 5060, it needs to be specified in the phone for the registration.


(United Kingdom) #3

hi,
already tried that one tried with 5060 and 5212 on both the phone and the extension tab


#4

Was 5212 a random guess?

Are you listening on 5060 for chan_sip?


(United Kingdom) #5

I originally was using 5060, but read on another forum to use a unique port for all the phones and they suggested using the extension number so I chosen 5212 . I have since moved it back to 5060 on both the phone and in the extensions tab. How would I check if it’s listening in on 5060 please


#6

In the chan_sip settings page, it would tell you

In the extension page also, it should also say what technology and port it is listening on.


(United Kingdom) #7

Both are set to 5160. I have changed the phone to that, still nothing.

On the extension if I edit it under the advanced tab in the edit extension part under port do I need to set that to 5160 as well. At the moment it’s still 5060 yet when I click on the general tab it states “ This device uses CHAN_SIP technology listening on Port 5160 (UDP)”


#8

The Phone, and the extension and the port and the protocol and the channel driver all have to agree , chan_sip by default uses UDP/5160 chan_pjsip uses UDP/5060, you are probably better off changing the extension to use chan_pjsip (or deleting it it and recreating it as a chan_pjsip extension (less comprehension needed that way :slight_smile: ))


(United Kingdom) #9

Struggling to get my trunk to connect using pjsip. I only been able to connect using chansip. I have followed sipgate’s pjsip setup guide but it doesn’t show as being connected.


#10

Yet you are listening on port 5160 for chan_sip, (trunks are not extensions and you are likely using ‘registration’ for yours :wink: , just try what I suggested maybe ?)

You will have to fix your trunk to pjsip sooner rather than later, maybe someone can help here


(Ted Mittelstaedt) #11

I have a couple of Grandstreams for testing. As I recall they are limited to a max of 8 characters for the password/secret. A surprising number of older phones are.