Confusing Zulu Mobile Behavior


(Bryce Holland) #1

I have setup Zulu on other appliances that are working just fine, so this is quite confusing. This appliance is PBXAct 15 with Asterisk 16. Here is the situation:

  • User is on home Internet --> Zulu app logs in and connects just fine --> WebRTC won’t connect
  • User is on mobile data --> Zulu app logs in, connects, and WebRTC works perfectly

This has to be a NAT issue, but I have replicated my settings from my other working appliance. I am using the ICE option to map the local IP of the appliance to the public IP, which has proved to be more reliable than setting a STUN URL.

Anyone have any ideas? I REALLY do NOT want to switch to Sangoma connect right now if I don’t have to. It is still too new, plus I am very uncomfortable with opening the SIP ports publicly. That was the advantage of Zulu.


(Matthew Fredrickson) #2

Which ICE option are you referring to?

Usually using stun/turn is the gold standard of NAT traversal - perhaps there were some issues with your stun server?


(Bryce Holland) #3

Thank you for your reply.
In Asterisk SIP Settings --> General SIP Settings tab --> ICE Host Candidates. I set the candidate to map the local IP of the PBX to the external IP. You can’t set a STUN server at the same time. Also, setting a STUN server in the “Media Transport Settings” as per the Zulu documentation wreaked havoc on my Sangoma desk phones, since it caused them to try and use the STUN server as well, even for internal calls.
I did try setting a STUN server address for the “WebRTC Settings” but that didn’t help.