Conflicting upgrade info re: adv_recovery & Endpoint Manager

FreePBX 15.0.23 / all modules up to date

The System Overview window in the FreePBX Dashboard is saying:

Critical Errors Found:
You have a disabled module
The following modules are disabled because they need to be upgraded:
adv_recovery
You should go to the module admin page to fix these.

$ sudo fwconsole ma upgradeall
No repos specified, using: [commercial,standard] from last GUI settings

Module(s) requiring upgrades: adv_recovery
Upgrading module ‘adv_recovery’ from 15.0.49 to 15.0.49
Downloading module ‘adv_recovery’
Processing adv_recovery
Verifying local module download…Verified
Extracting…Done
Download completed in 1 seconds
Detected Missing Dependency of: endpoint 15.0.43.1
Downloading Missing Dependency of: endpoint 15.0.43.1
Processing endpoint
Verifying local module download…Verified
Extracting…Done
Module endpoint successfully downloaded
Installing Missing Dependency of: endpoint 15.0.43.1
Create symlink…Done
Checking database tables…Done
Migrating tables as required…Done
Checking Settings and Defaults…Done
Generating Configs…Done
Downloading Firmware…Done (Background)
Generating CSS…Done
Installed Missing Dependency of: endpoint 15.0.43.1
Dependency module endpoint version 15.0.43.1 is Enabled
Unable to install module adv_recovery:
- EndPoint Manager module version 15.0.43.1 or higher is required, you have 15.0.39.49
Updating Hooks…Done
Chowning directories…Done
All upgrades completed successfully!
Updating Hooks…Done
Chowning directories…Done
$ sudo yum update
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
No packages marked for update
$

As I read the log above, it says Endpoint Manager 15.0.43.1 has been installed, then claims adv_recovery can’t be installed because Endpoint Manager 15.0.43.1 or higher is required.

Am I missing something obvious? Please advise.

And now, when I “Apply Config”, the following error message appears:

Error!
There was an error during reload: Unknown Error. Please run fwconsole reload --verbose

Here’s the result:

$ sudo fwconsole reload --verbose
[sudo] password for stewart:
Reload Started
touch: cannot touch ‘/etc/asterisk//etc/asterisk/extensions_custom_scripter.conf’: No such file or directory
[ERROR] Error code 1: trying to create empty file /etc/asterisk/"/etc/asterisk/extensions_custom_scripter.conf"
touch: cannot touch ‘/etc/asterisk//etc/asterisk/extensions_custom_scripter.conf’: No such file or directory
[ERROR] Error code 1: trying to create empty file /etc/asterisk/"/etc/asterisk/extensions_custom_scripter.conf"
Reload Complete
$ sudo ls -l /etc/asterisk/extensions_custom_scripter.conf
-rw-rw-r-- 1 asterisk asterisk 0 Dec 25 2020 /etc/asterisk/extensions_custom_scripter.conf
$

Re-running “Apply Config” gives the same error as above.

Arghhhhhhhh!

From the Module Admin module it appears that Endpoint Manager 15.0.43.1 was not actually installed (as it appeared to say in the log referenced above), and remains at Endpoint Manager 15.0.39.49. I expect that the license for EPM has expired, but I really don’t intend to pay any more for EPM. So my questions now are:

  1. If adv_recovery is removed, will that fix my issue?
  2. If question 1 is yes, then how do I remove adv_recovery?

Hi @sgseidel
You are talking about 2 different issues here.

  1. Advanced recovery module getting disabled due to endpoint dependency.
  2. Error while running reload.

You can resolve issue number one by removing adv_recovery module (if you are not using) and rollback to endpoint module older version or purchase module update for EPM.

Issue number two seems to be coming from your custom configuration.

I’ve got the same issue. I uninstalled adv_recovery. Still can’t update endpoint manager. I also have purchased endpoint manager…

@psanddesh Thanks for your reply.

OK, issue #1, how do I remove adv_recovery?

Issue #2. I have been running FreePBX 15 for a couple of years, keeping FreePBX current with “sudo yum update” and “sudo fwconsole ma upgradeall” every few days as required. I have NEVER seen this issue. As far as I know I do not have a custom configuration, it’s pretty much stock.

Please advise. Thanks.

IF you’re using the paid version of EPM, upgrades require that the maintenance period be current.
https://wiki.freepbx.org/display/FPAS/How+to+Renew+FreePBX+Commercial+Modules+Maintenance

If the module maintenance is current, you can upgrade with the command:

fwconsole ma downloadinstall endpoint --tag 15.0.43.3

Paid commercial modules with maintenance up to date include free support:
https://wiki.freepbx.org/display/FPAS/How+To+Open+A+Support+Ticket

I’ve got maintenance current on epm.

1 Like

I managed to uninstall adv_recovery (I’m not exactly sure what worked, but that’s another story). The system was rebooted and now after “Apply Config”, the “System Alert” box is green and “No critical issues” is displayed. This is good.

Thanks to all for your assistance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.