Configuring Twillio


(Stephan Koenig) #1

I have googled around a lot and tried so many things. I am sure the answer is very simple, but I can’t figure it out.

We use Sipstation and are very happy with it.

We have Twillio as an outbound sip trunk for backup in case Sipstation fails and for some international calls. This works since a long time.

Now I was asked to add an inbound number to Twillio as well that could be used if Sipstation is down.

I now have a number in Twillio and their Elastic SIP Trunking Origination settings point it to my FreePBX. And I have created an inbound route for that number.

I did not change the configuration of that sip trunk as it is working fine outbound. But inbound I can not get it to work.

6[2020-11-14 14:42:29] NOTICE[19702] res_pjsip/pjsip_distributor.c: Request ‘INVITE’ from ‘<sip:+172728811111@xxx.pstn.twilio.com>’ failed for ‘54.244.51.0:5060’ (callid: 98945cf84e3db4434fad6d0a870e1620@0.0.0.0) - No matching endpoint found

I have tried setting Twillio to sip: and sips: and the ports 5060, 5061, and 5160. Nothing worked.

Any hints?


(Itzik) #2

What is your trunk settings?
(PJSIP guide)


(Stephan Koenig) #3

Yes I know that document.

I have had this trunk since many years. In the outgoing setting:
host=x.pstn.twilio.com
username=aaaaaaa
secret=bbbbbbb
type=peer
qualify=no

Nothing in the incoming settings.


(Stephan Koenig) #4

This is a SIP trunk not a PJSIP.


(Lorne Gaetz) #5

The invite is coming in on the PJSIP port.


(Stephan Koenig) #6

Thanks, Lorne. So that means I need to configure this trunk as PJSIP and delete the old configuration?


(Lorne Gaetz) #7

That or send the inbound calls to the correct port.


(Stephan Koenig) #8

The only port that I have open right now is 5061. I am trying to point Twillio to that port, but it does not work.

sip:koenighome.dyndns.org:5061

NOTICE[11377] res_pjsip/pjsip_distributor.c: Request ‘INVITE’ from ‘<sip:+xxxxxxxxxxxxxxxx@yyyy.pstn.twilio.com>’ failed for ‘54.244.51.1:5060’ (callid: 59aab91bfff17789749cedca3453d6b5@0.0.0.0) - No matching endpoint found

I also tried
sip:koenighome.dyndns.org:5061
but that does not even show up in the logs.

I guess I need to use a different port as Twillio uses PJSIP only?


(Itzik) #9

Seems like Twilio uses 5060 only, and you have PJSIP on 5060.
Try setting up a PJSIP Trunk.


(Stephan Koenig) #10

Okay, I have it solved. Test calls came in from different IPs than my cell phone tests.

I had to enable all IPs.

I did this in the pjsip setting, advanced, Match (Permit) and added all IPs there.

THANKS FOR ALL YOUR HELP!


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.