Configuring Trunk -

Hi everyone,

After a morning of googling, reading documentation and trail and error I have still been unsuccessful setting up this sip trunk with (an Irish Provider).

I have a dynamic IP from my ISP but am using DynDNS with ports 5060 and 10000-20000 udp forwarded on my router.

I’ve installed FreePBX as part of PBX in a Flash and I’m on FreePBX v2.6.0.

The provider has given me credentials like this (this is just a test account I’m using temporarily) -

Extension from other Blueface Users: 308180
From other VoIP users: [email protected]
Irish Geographic Number: None assigned, contact us for more details.
Irish Geographic Access Number: +353-1-5242025 extn: 308180
Irish VoIP Number: 35376XXXXXXX
Voicemail: 171 (PIN XXXXX)

I also have a username and passsword -
Username: myusername (notice, this is not a number)
Password: mypassword

Here is the configuration I am using in FreePBX:

Trunk Description - Blueface
Outbound Caller ID - 353766033163
Maximum Channels - 2

Dial Rules : I’m not sure what to put here because the American examples seem different for my country. Here is an example of a number in my area 01-6334987 - the area code is 01 followed by 7 digit number.

Here is an example of another location in my country - 090-5432897 - here the area code is 090.

Basically I want ALL calls to go out over this trunk. I do not have any other trunks as I am testing.

Trunk Name: Blueface
username=myusername(as explained above)

Incoming Settings:
I don’t understand any of these settings here, could someone please explain?

Register String:
username:[email protected]

Apologies for the long post and thanks in advance,


Hi Dont know if you got a reply to your post but it would easier if you got Blueface to open a iax connection on your account.

using the Iax connection means you would only need to open UDP port 4569. and not all the above ports

On your out going settings add the below in the box

fromuser=type your blueface account name here
secret= type account password here
username=type your blueface account name here

On the incoming setting you will need to add the below in the box


Register String:
username:[email protected]

make you sure you have forward the ports to your FreePbx

let me know if you need any more help