Configuring Grandstream HT813 with POTS line from ONT (ISP) etisalat

Good day, I recently, bought an HT813 with the hopes of running freePBX, and changing my home’s phones to IP phones. I have tried the following tutorials, and references without any success unfortunately.

I currently use Etisalat’s ONT to get the line. Plugging a normal phone supplied by them works immediately. However, plugging the POTS1 line to the FX0 port on the HT813 does not do anything. On top of that the FXS line which is connected to the supplied analog phone keeps blinking.

 2021-05-19 13:22:56] WARNING[7159] res_pjsip_registrar.c: AOR '' not found for endpoint 'Test' (
11648[2021-05-19 13:22:56] WARNING[7159] res_pjsip_outbound_registration.c: '405' fatal response received from 'sip:' on registration attempt to 'sip:[email protected]', retrying in '30' seconds

I have no idea, what the error is caused by. But It is not configuring properly even though it shows it is online. Please feel free to ask for what you need. I am not very knowledgeable, but I will try my best to provide you with more details.

The most important part for the FXO port is the field “unconditional forward to VoIP”. You need to define a trunk with a numeric name and point that field to the trunk’s name. Don’t use registration for the FXO, at least not until you have it working correctly.

Thanks for your quick reply!

I have set the unconditional forward to VoIP using the number which my ISP gave me. So, it would be [email protected]:5060

As for the username, Auth username, and secret; I have followed the tutorial by putting the same number above to make sure it works.

Authenticate ID
secret are also the same

The PJSP SIP settings were confusing, there was another SIP server field where i placed the ip of the grandstream and the port being 5062, and context as “from-trunk”

In the grandstream, do I need to configure the " AC Termination Model" if yes I couldn’t find my country.

The unconditional forward must be the name of the trunk and the trunk’s name should be numeric. If you used the same number that your provider gave you to name your trunk, then it is ok. If you used another number as the name, then use that number in the unconditional forward field. Do not configure authentication at least until you have it working. AC termination model should be the set to the value your provider uses.

It does the authentication without me doing anything. As for the AC termination, isp is not giving any clues

The tutorial shows the trunk set up with Registration: Receive. But your pjsip shows an outbound registration.

When you get that fixed, if the HT still doesn’t register, report any errors logged.

If it does register, report what happens on attempted inbound and outbound calls.

Just a point of fact, the Grandstream ATA’s don’t “need” a pbx, they can function totally standalone between your vsp and your connected FSX analog phones if that is all you need.

Thanks for your reply, I am trying to set up the intercom system (if the naming is correct), where I can dial extensions for different rooms. 1 line provided by the ISP, will ring all those phones, until someone picks up. Also, my other side goal is to get the hikvision door station to integrate with the ip phones to ring, and answer/open door based on who’s outside. It may be an non-feasible goal, but I’d like to pursue it for learning purposes.

If I may ask, how do I set up without outbound registration?

Not with an 813, an 814 you could do 4 rooms an 818 8, given bigger GS, intercom dialing VSP calling to and from all phones and and the door thing could be all be done sans PBX

The HT is not a SIP server so it is not possible for Asterisk to register to it. The two choices are static configuration (each device is set up with the IP address of the other), or the HT registers to Asterisk.

The first tutorial author chose the latter, which is why he specified Registration Receive for the trunk.

1 Like

I have set it up in freepbx GUI using the Grandstream’s HT IP, and on the Grandstream vice versa. However, it only led to that registration issue.

That’s why I installed freepbx. I’d like to learn how I can intercom dial, and recieve/send the call on one of the phones. Our house had the legacy NEC SL1000, but now it is not working anymore. So I have shifted to the freepbx + ip phones.

Hey guys, this is just an update on the issue. So, it turns out the call is received on asterisk, but freePBX replies with “The number you have dialed is not in service 0xxxxxxxx”.

Also: I have disabled registration, but I don’t know if that helps.

You don’t have the appropriate inbound route to receive the incoming call.

1 Like

Thanks, I will get to it as soon as possible. There is a video from crosstalk solutions talking about inbound routes used as a catch all. Would that suffice?

Yes, an “any/any” route (no inbound DID and no inbound CID) will catch literally every phone number that comes in. From there, you can look in the /var/log/asterisk/full log file to get the DID phone number that’s actually coming in.

I have Successfully configured both Inbound, and Outbound routes without any problems. I can now receive calls, as well as make calls from the devices I have. Last thing would be to fix the latency as in the time taken to make the call, and the time to receive the call. If there are any insights on how to decrease those I would be very grateful. Thanks for keeping up with me, and guiding me through the way.

Will do, thanks!

For outbound, check that the dial plan (sometimes called digit map) is sending the call to Asterisk as soon as you press the last key. If you can speed the call along by pressing Send or # after the number, the dial plan is likely incorrect for your country.

On inbound, try setting Number of Rings on the FXO page of the HT to 1. If you don’t get the caller ID, try 2. If the carrier isn’t providing caller ID, try 0.

If you still have latency trouble, paste the Asterisk log for a call at and post the link here, along with an accurate timestamp of when you pressed the last key (outbound) or the caller heard the first ring (inbound).

1 Like