Configuring Cisco 7975 IP Phone Help!


(Dave Burgess) #24

No - the MariaDB service is just one of the services running on the server. You should be able to do

systemctl status mariadb.service

to get the status of the server. It could be that the service is taking some time to restart.


(Ryan) #25

Ok. I’ll give it another go and report back.


(Ryan) #26

Here is the error I’m getting in the ssh console:

[root@freepbx ~]# systemctl restart mariadb.service
Job for mariadb.service failed because the control process exited with error code. See “systemctl status mariadb.service” and “journalctl -xe” for details.
[root@freepbx ~]# systemctl status mariadb.service
● mariadb.service - MariaDB database server
Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Fri 2020-02-07 10:03:16 PST; 14s ago
Process: 4167 ExecStartPost=/usr/libexec/mariadb-wait-ready $MAINPID (code=exited, status=1/FAILURE)
Process: 4166 ExecStart=/usr/bin/mysqld_safe --basedir=/usr (code=exited, status=0/SUCCESS)
Process: 4123 ExecStartPre=/usr/libexec/mariadb-prepare-db-dir %n (code=exited, status=0/SUCCESS)
Main PID: 4166 (code=exited, status=0/SUCCESS)

Feb 07 10:03:08 freepbx.sangoma.local systemd[1]: Stopped MariaDB database server.
Feb 07 10:03:08 freepbx.sangoma.local systemd[1]: Starting MariaDB database server…
Feb 07 10:03:08 freepbx.sangoma.local mariadb-prepare-db-dir[4123]: Database MariaDB is probably initialized in /var/lib/mysql already, nothing is done.
Feb 07 10:03:09 freepbx.sangoma.local mysqld_safe[4166]: 200207 10:03:09 mysqld_safe Logging to ‘/var/log/mariadb/mariadb.log’.
Feb 07 10:03:10 freepbx.sangoma.local mysqld_safe[4166]: 200207 10:03:10 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
Feb 07 10:03:16 freepbx.sangoma.local systemd[1]: mariadb.service: control process exited, code=exited status=1
Feb 07 10:03:16 freepbx.sangoma.local systemd[1]: Failed to start MariaDB database server.
Feb 07 10:03:16 freepbx.sangoma.local systemd[1]: Unit mariadb.service entered failed state.
Feb 07 10:03:16 freepbx.sangoma.local systemd[1]: mariadb.service failed.

Here’s the log:

200207 10:03:08 mysqld_safe mysqld from pid file /var/run/mariadb/mariadb.pid ended
200207 10:03:10 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
200207 10:03:10 [Note] /usr/libexec/mysqld (mysqld 5.5.60-MariaDB) starting as process 4403 …
200207 10:03:10 InnoDB: The InnoDB memory heap is disabled
200207 10:03:10 InnoDB: Mutexes and rw_locks use GCC atomic builtins
200207 10:03:10 InnoDB: Compressed tables use zlib 1.2.7
200207 10:03:10 InnoDB: Using Linux native AIO
200207 10:03:10 InnoDB: Initializing buffer pool, size = 128.0M
200207 10:03:10 InnoDB: Completed initialization of buffer pool
200207 10:03:10 InnoDB: highest supported file format is Barracuda.
200207 10:03:10 InnoDB: Waiting for the background threads to start
200207 10:03:11 Percona XtraDB (http://www.percona.com) 5.5.59-MariaDB-38.11 started; log sequence number 55716167
200207 10:03:11 [Note] Plugin ‘FEEDBACK’ is disabled.
200207 10:03:11 [ERROR] /usr/libexec/mysqld: unknown variable ‘group_concat_max_length=8192’
200207 10:03:11 [ERROR] Aborting

200207 10:03:11 InnoDB: Starting shutdown…
200207 10:03:15 InnoDB: Shutdown completed; log sequence number 55716167
200207 10:03:15 [Note] /usr/libexec/mysqld: Shutdown complete

200207 10:03:15 mysqld_safe mysqld from pid file /var/run/mariadb/mariadb.pid ended


(Dave Burgess) #27

Your version of MariaDB isn’t the one that the manager is expecting. Comment out the line and restart MariaDB


(Ryan) #28

So comment out this line: “group_concat_max_length = 8192” ?


(Ryan) #29

I seemed to have fixed it. I used “group_concat_max_len = 4096” and left off “or more” from the line. The error in sccp manager has gone away.


(system) closed #30

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.