Configuring calls to use Opus in FreePBX installed from ISO

Hello friends,

I am using FreePBX which I installed from SNG7-PBX-64bit-2104.iso (Free PBX ISO). I am have set up a line to answer and play a recording. I am testing it using a software phone, Zoiper for MacOS. Currently when I make the call, Zoiper reports that the code used was G.711 mu-law. I want to be able to use Opus with FEC. I have moved Opus to the top of the list of codec options in Zoiper under Account Settings->Advanced. I need to do something similar in FreePBX, but I am not sure where to find this setting. It appears that Opus is installed because when I type “core show translation paths opus”, various outputs appear and also because and codec_opus.manifest.xml both appear in /usr/lib64/asterisk/modules/. This leads me to believe Opus is pre-installed with the FreePBX ISO. Is there a setting to force it to use Opus for the call?

Thanks in advance for any help.

You can set in Settings > Asterisk SIP Settings for the defaults. You can also change individual extensions under the Advanced Tab.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.