Configuration Source SIP UDP Port in Trunk


(Andreas Fendt) #1

Hello,

I have a FreePBX 15.0.16.22 running on a Rasperry Pi and am actually very happy with this phone system. I have two SIP trunks going to the internet and probably my firewall gets a bit confused with the outgoing UDP connections. The first SIP trunk can still be registered without problems and with the second one no UDP packets come back from the SIP server. Probably these are blocked by the firewall.

Now my question is: how can I change the soure port of the UDP connection in the SIP trunk?

Many greetings
HyP3r


#2

You could set up one trunk on pjsip and the other on chan_sip. However, that is a frail solution and it would preclude having external extensions.

If your firewall has a SIP ALG setting, try turning that off. In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set.

If no luck, please post:
ISP? Modem make/model? Router/firewall make/model? Any VoIP related settings?


(Andreas Fendt) #3

You could set up one trunk on pjsip and the other on chan_sip. However, that is a frail solution and it would preclude having external extensions.
I plan to create more SIP trunks, so it is unfortunately no solution for me to operate the second trunk as chan_sip.

If your firewall has a SIP ALG setting, try turning that off. In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set.
I am not aware that the firewall that I have active SIP-ALG functions. In the field “External Address” I have stored the DynDNS host name because the customer has a static IPv4 address.

If no luck, please post:
ISP? Modem make / model? Router / firewall make / model? Any VoIP related settings?
The ISP is Deutsche Telekom. The modem is an AVM FRITZ! Box 7530 AX. What do you mean by “Any VoIP related settings?”


#4

Confusing, Having a Static IPv4 address precludes the need for dynamic addressing