Configuration Advice in FreePBX with

As a non-IT person that’s been hacking away with guides all week (and finally seem to have everything working), I wanted to see if I couldn’t get some opinions on how to improve my setup, which seems a bit cumbersome to me.

PBXact with Everything is update and using Zulu 3 as well (in addition to the other typical modules that I would need to setup).

My test setup has three endpoints. I have four DIDs from Four trunks set up in my PBX. Each endpoint has two extensions (account 1 and account 2). Each trunk has its own outbound and inbound route.

One trunk is a “Main Office” line that rings all three phones at once on the DID associated with that. (Each phone also has an extension which is the Account 1 for eventual use with an IVR.) Single outbound route used by account 1 on every phone so the main company phone number is the CID.

Three other trunks are all the direct lines, that route each of the three phones with their own DID. (I set this up so that users could have a direct line that would act as a “mobile” line for customers to contact direct if necessary. Did it this way so that it could either ring at their desk or they can set up Zulu on their phones for this extension as well and have a mobile solution. It would allow employees to call customers back either from mobile or desk phones on their “direct/mobile” line and the CID would be that number.)

This seemed a little cumbersome to me, but I didn’t think that Zulu was designed to work as strictly a softphone, so adding the second account to each phone was the solution for that. That part doesn’t seem too clunky.

The cumbersome part was the four trunks. It seemed to me that I should be able to make a single trunk with my main account at and have all the extensions use this and have CID override settings for each extension. However I couldn’t get the CID override to work. (I’ve seen a bunch of posts about that and tried most of it, the only thing I can figure is that my account settings at are prohibiting this. I have a support ticket in to request information on this as it’s my last place to troubleshoot.)

Like I said I just wanted to make sure that even though it’s cumbersome that I’m not doing something that’s just way wrong and definitely going to cause problems down the road. The multiple trunks and subaccounts seemed an obvious place for issues (but I guess a single issue wouldn’t take down the entire system like it would if it was only on a single account).

Any advice on how to make this better is appreciated. And like I said this is not my field at all so you may have to explain it to me like I’m an idiot. I won’t take offense, I’m very honest with myself :joy:

A single trunk should be fine. Make sure that you have selected “I use a system capable of passing …”; see
Also, confirm with a SIP trace that you are sending a properly formatted caller ID in the Remote-Party-ID header. At the Asterisk command prompt, type
sip set debug on
(if using a chan_sip trunk) or
pjsip set logger on
(if using pjsip)
make a test call and look at the headers in the outgoing INVITE.

If you are reasonably sure that this is all correct, you should indeed open a ticket.

On incoming with a single trunk, set the context to from-pstn-toheader so the PBX knows which DID was called.

You may find
useful, especially if you are in Canada.

I think the “using a system capable…” option is most likely what I have set up incorrectly. I haven’t had another chance, but I will try that again first opportunity.

I recalled that option after a good deal of troubleshooting in my freepbx setup and realized it may have something to do with it. If I recall correctly I had issues with account registration while making and receiving calls which is why I enabled the specific DID option, but I think that there are other registration issues with that I’m troubleshooting and hopefully that will solve the problem.

I’ll test that once I get it set up. I appreciate the help with this. It’s a good feeling finally figuring something out that was way beyond my skillset, but it’s awfully tedious getting there!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.