Configura Smartphone


(Domenico) #1

Buongiorno a tutti
ho installato freepbx per raspberry, eseguito upgrade con esito positivo.
Creato\registrato due interni con zoiper, uno su PC l’ altro su smartphone, internamente tutto OK. In seguito ho utilizzato Messagenet come Voip per le chiamate uscita\ingresso. creato trunk, in e outbond. Test chiamate con esito positivo.

Ora volevo configurare interno dello smartphone con zoiper per poter essere usato anche fuori dalla rete locale… ho un modem Fastweb

Mi potete dare una mano ?


(Danilo Smaldone) #2

Ciao @Domgi
di sicuro devi effettuare qualche port forward per poter consentire ai terminali esterni alla rete di raggiungere il PBX
Ecco qui un elenco di porte che ti può aiutare
https://wiki.freepbx.org/display/PPS/Ports+used+on+your+PBX

Di norma basta effettuare il forward della porta SIP e range RTP


(Domenico) #3

Ciao e grazie

Presumevo apertura porte, unico problema è che il modem Fastweb la porta 5060 non me la fà gestire perchè è in uso…


(Danilo Smaldone) #4

Vai in Asterisk SIP Settings e modifica la porta SIP che usi sul tuo sistema da 5060 a una di tua scelta.

Usare trunk SIP su modem che già “fanno VoIP in SIP” causa questi problemi. In più a volte interviene il SIP ALG di tali modem.

Se ti sposti su una porta alternativa, puoi fare port forward e usare il sistema FreePBX in contemporanea con la tua normale linea VoIP


(Domenico) #5

Ok grazie
Presumevo che era così ma non riuscivo a registrare interno
poi ho capito che su zoiper il numero della porta è da mettere dopo indirizzo IP
XXX.XXX.XXX.XXX : XXXX porta

io cercavo nelle opzioni

ora funziona bene.

Grazie alla prossima


(Domenico) #6

Mi sono esaltato troppo…
La connessione\registrazione ok
Ma non sento audio in entrambe le direzioni.
Aperto UDP 10.000\20.000 ma nulla
Open UDP SIP 5800

BOH…


(Domenico) #7

Cade la connessione pare per mancanza RTP, ho configurato 15 secondi timeout
e dopo di 15 secondi cade la linea…


#8

Please excuse my writing in English.

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. If you change these, you must restart Asterisk.

If you still have trouble, report the simplest thing that fails. For example, does calling *43 (echo test) work correctly? If so, does a call from an external extension to an internal extension have audio in either direction?


(Domenico) #9

Thank Stewart 1
My my English is basic, sorry :=)))

External address and Local Network in SIP Setting is OK.
i call a number internal, fox example 200, but no audio in and out.


(Domenico) #10

Echo test is OK


(Domenico) #11

Now I call internal 200 and the voice is OK… boh


#12

If the problem is intermittent (some calls fail and some don’t), it’s likely that your router/firewall is rewriting port numbers in an inconsistent way.

What is the Fastweb modem model? What special settings do you have (post screenshots if appropriate)?

Is the Pi connected directly to the Fastweb modem? If not, tell us the make and model of the router, and what special settings you have.


(Domenico) #13

the Internal number is 200, on my PC whit zoiper
the External number is 201 on my smartphone whit zoiper

If internal 200 call 201, the voice after 30 second is down for lack audio rtp
if internal 201 call 200, the voice all OK

PI connected to router fastweb H388Q V7.0 directly

Open ports UDP

10000 \ 20000
SIP PORT 5800

res_pjsip_sdp_rtp.c: Disconnecting channel ‘PJSIP/201-00000032’ for lack of audio RTP activity in 30 seconds


#14

At the Asterisk command prompt, type
pjsip set logger on
you should see
PJSIP Logging enabled
Make a test call from 200 to 201, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.


(Domenico) #15

https://pastebin.freepbx.org/view/d77bdae0

risponde con una porta UDP 37954


#16

The snippet you pasted does not show a problem – it is normal for Fastweb (the mobile carrier) to have a NAT that modifies port numbers. Please paste the complete log for the call (several hundred lines).

For example: Note the time. Make your test call and wait for the disconnect for lack of RTP. In the Asterisk logfile ( /var/log/asterisk/full ), find the first entry after you started the call (it is probably an INVITE received) and paste from there to the end of the log.


(Domenico) #17

ok
but… my ip pubblic ? all see…


#18

Before pasting the log, use an editor to replace all instances of your public IP with e.g. 93.33.1xx.xxx (keep enough information to we can distinguish your address from the mobile carrier’s address).

Or, replace all instances of your public IP with ppp.ppp.ppp.ppp and all instances of the mobile carrier’s address with mmm.mmm.mmm.mmm

Or, whatever you want, as long as it remains clear what each address stands for.


(Domenico) #19

https://pastebin.freepbx.org/view/bba86035

aaa ip asterisk
mmm ip mobile
200 ip internal 200

fff IP Fastweb


#20

So far, I see nothing wrong at the PBX end. Line 323 shows Asterisk requesting audio to the correct address (its public IP) and line 325 shows a reasonable port number. However, the audio never seems to arrive.

Check that for the extensions RTP Symmetric, Rewrite Contact and Force rport are all Yes and that Direct Media is No.

Check that the port forwarding settings in the Fastweb modem are correct. You should be forwarding UDP ports 10000-20000 to aaa ports 10000-20000.

If no luck, run a packet capture of a failing call on the PBX, for example
tcpdump -s 0 -w foo.pcap
After the call, type ctrl-C to stop tcpdump, copy foo.pcap to your PC, open it in Wireshark and look at what RTP is flowing. If things were working properly, you should see RTP from 200 to aaa, from aaa to mmm, from mmm to aaa, and from aaa to 200.