Conference through iax

Hi,

Does anybody knows if it is possible to use Conference through iax.

Our pbx is connected to anothers asterisk machine through IAX
So all inbound calls will be send from a external asterisk IVR server to the PBX server.
So there for we don’t use any zap drivers (No hardware for ISDN lines)

When I try to send a call (through IAX) to a conference room (900) I get te call dat it is not a valid conferance room.
Does anybody knows how to solve this issue?

Here CLI:
– Executing [[email protected]:2] Set(“IAX2/192.168.230.35:4569-13”, “MEETME_ROOMNUM=900”) in new stack
– Executing [[email protected]:3] Set(“IAX2/192.168.230.35:4569-13”, “MAX_PARTICIPANTS=10”) in new stack
– Executing [[email protected]:4] Set(“IAX2/192.168.230.35:4569-13”, “MEETME_MUSIC=”) in new stack
– Executing [[email protected]:5] GotoIf(“IAX2/192.168.230.35:4569-13”, “0?USER”) in new stack
– Executing [[email protected]:6] Answer(“IAX2/192.168.230.35:4569-13”, “”) in new stack
– Executing [[email protected]:7] Wait(“IAX2/192.168.230.35:4569-13”, “1”) in new stack
– Executing [[email protected]:8] Set(“IAX2/192.168.230.35:4569-13”, “MEETME_OPTS=ocIMs”) in new stack
– Executing [[email protected]:9] Playback(“IAX2/192.168.230.35:4569-13”, “beep”) in new stack
– <IAX2/192.168.230.35:4569-13> Playing ‘beep’ (language ‘en’)
– Executing [[email protected]:10] Goto(“IAX2/192.168.230.35:4569-13”, “STARTMEETME|1”) in new stack
– Goto (ext-meetme,STARTMEETME,1)
– Executing [[email protected]:1] ExecIf(“IAX2/192.168.230.35:4569-13”, “0|Set|CHANNEL(musicclass)=”) in new stack
– Executing [[email protected]:2] Set(“IAX2/192.168.230.35:4569-13”, “GROUP(meetme)=900”) in new stack
– Executing [[email protected]:3] GotoIf(“IAX2/192.168.230.35:4569-13”, “0?MEETMEFULL|1”) in new stack
– Executing [[email protected]:4] MeetMe(“IAX2/192.168.230.35:4569-13”, “900|ocIMs|”) in new stack
== Parsing ‘/etc/asterisk/meetme.conf’: Found
== Parsing ‘/etc/asterisk/meetme_additional.conf’: Found
[Apr 15 08:32:22] WARNING[24737]: app_meetme.c:772 build_conf: Unable to open pseudo device
– <IAX2/192.168.230.35:4569-13> Playing ‘conf-invalid’ (language ‘en’)
== Spawn extension (ext-meetme, STARTMEETME, 4) exited non-zero on ‘IAX2/192.168.230.35:4569-13’
– Executing [[email protected]:1] Hangup(“IAX2/192.168.230.35:4569-13”, “”) in new stack
== Spawn extension (ext-meetme, h, 1) exited non-zero on ‘IAX2/192.168.230.35:4569-13’

Regards,

Arjan Kroon

To use conferencing you need a timing device like a dahdi dummy device.

Oke, Thanks.
Is there a module which I can download and install for Freepbx 2.8.1.4.

Download dahdi from digium:

cd /usr/src
wget http://downloads.digium.com/pub/telephony/dahdi-linux-complete/dahdi-linux-complete-current.tar.gz
tar -zxvf dahdi-linux-complete-current.tar.gz

Check the directory created substiture the X’es for the version number

cd dahdi-linux-complete-X.X.X+X.X.X
make
make install

Then you need to restart your server.

I’ve installed the drivers en reboot the server.
But still got the same message.

here the CLI logging.

-- Executing [[email protected]:2] Set("SIP/290-b7908828", "MEETME_ROOMNUM=900") in new stack
-- Executing [[email protected]:3] Set("SIP/290-b7908828", "MAX_PARTICIPANTS=10") in new stack
-- Executing [[email protected]:4] Set("SIP/290-b7908828", "MEETME_MUSIC=") in new stack
-- Executing [[email protected]:5] GotoIf("SIP/290-b7908828", "0?USER") in new stack
-- Executing [[email protected]:6] Answer("SIP/290-b7908828", "") in new stack
-- Executing [[email protected]:7] Wait("SIP/290-b7908828", "1") in new stack
-- Executing [[email protected]:8] Set("SIP/290-b7908828", "MEETME_OPTS=ocIMs") in new stack
-- Executing [[email protected]:9] Playback("SIP/290-b7908828", "beep") in new stack
-- <SIP/290-b7908828> Playing 'beep' (language 'NL')
-- Executing [[email protected]:10] Goto("SIP/290-b7908828", "STARTMEETME|1") in new stack
-- Goto (from-internal,STARTMEETME,1)
-- Executing [[email protected]:1] ExecIf("SIP/290-b7908828", "0|Set|CHANNEL(musicclass)=") in new stack
-- Executing [[email protected]:2] Set("SIP/290-b7908828", "GROUP(meetme)=900") in new stack
-- Executing [[email protected]:3] GotoIf("SIP/290-b7908828", "0?MEETMEFULL|1") in new stack
-- Executing [[email protected]:4] MeetMe("SIP/290-b7908828", "900|ocIMs|") in new stack

== Parsing ‘/etc/asterisk/meetme.conf’: Found
== Parsing ‘/etc/asterisk/meetme_additional.conf’: Found
[Apr 15 12:05:46] WARNING[4593]: app_meetme.c:772 build_conf: Unable to open pseudo device
– <SIP/290-b7908828> Playing ‘conf-invalid’ (language ‘NL’)
== Spawn extension (from-internal, STARTMEETME, 4) exited non-zero on ‘SIP/290-b7908828’
– Executing [[email protected]:1] Macro(“SIP/290-b7908828”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/290-b7908828”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,4)
[Apr 15 12:05:50] DEBUG[4593]: app_macro.c:337 _macro_exec: Executed application: GotoIf
– Executing [[email protected]:4] GotoIf(“SIP/290-b7908828”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,7)
[Apr 15 12:05:50] DEBUG[4593]: app_macro.c:337 _macro_exec: Executed application: GotoIf
– Executing [[email protected]:7] GotoIf(“SIP/290-b7908828”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,9)
[Apr 15 12:05:50] DEBUG[4593]: app_macro.c:337 _macro_exec: Executed application: GotoIf
– Executing [[email protected]:9] Hangup(“SIP/290-b7908828”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 9) exited non-zero on ‘SIP/290-b7908828’

Have you compiled Asterisk by yourself? If so, then you must do this:
go to your Asterisk source directory and type
make clean
./configure
make
make install

If you do a make clean and than install, are all asterisk setting then gone?
For example special features which I programmed.

Just dont do a make samples, then restart asterisk, it won’t overwrite any configs.

Oke, thanks for the very quick help.
I will try this Monday morning.
And then I’ll let you know.