Complete server failure

I went into my server to add my google voice account and when I hit apply the whole server went completely crazy! The server disconnected from asterisk and the firewall is now in this loop saying "firewall Rules corrupted! Restarting in 5 seconds. Then on the dashboard it says the following: The command “/usr/sbin/asterisk -rx ‘core show version’” failed.

Exit Code: 1(General error)

Working directory: /var/www/html/admin


Error Output:

Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

Asterisk: OFFLINE: Unable to find asterisk results

Restapps Daemon: OFFLINE


NOTE: I just also completely update the server to the current versions as well.

Google Voice account? The ability to connect to Google Voice disappeared in the middle of 2018.

It might be your configuration that is causing Asterisk to fail. You can try disabling the Asterisk modules that are related to the old Google Voice connection. In the Asterisk Modules menu (not Modules), go to the Excluded Modules tab and add and See if that gets you out of this failure loop.

Can you restore from backup?

I had this in the past. You need to delete the module

It think it’s

fwconsole ma delete motif

Then there should be 3 motif files under /etc/asterisk/ delete these (or move it to the tmp folder)


fwconsole restart

And you should be good

Also if you’re tight on storage space, check your /tmp folder, you may have some core dumps to clear out depending on how long Asterisk has been crashing and restarting.

I tried to find the modules in the GUI and didnt see the ones listed.

I ran the command above and it executed successfully in the GUI but im unsure on how to navigate to the /etc/asterisk/

Honestly not sure how to do that. Sorry

What? Where in the GUI?

cd /etc/asterisk
ll | grep motif

then run

rm < filename >

for each file that you saw after running ll

They’re not listed; you type those module names into the “add” field under the excluded modules tab.

I am sorry I misread your message. This fixed all the issues I been having thank you so much!

The issue has been resolved. Thank you to each of you guys that took the time to help with this issue! you guys are the best.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.