Commercial System Admin module broken - gmail doesnt work

I just installed the full distro and updated all modules. I then purchased System Admin Pro.
I am trying to get gmail to work using the module instead of editing the postfix files manually.

Initially, the email debug screen showed a bunch of networking errors which I was able to track down to the fact my machine had installed IPv6 even though my network doesnt support it. I fixed this by adding
net.ipv6.conf.all.disable_ipv6 = 1
to the sysctl.conf file.

After rebooting I tried setting up gmail again and it still does not work.
I tried the following

  1. a gsuite account
  2. a gmail account
  3. allow insecure apps on gmail/gsuite
  4. manually setting authentication, port 587, smtp.gmail_com, etc

nothing i tried works. It seems the system admin module doesn’t change any of the config files for postfix. All the postfix files show default values. Are the changes written somewhere else?

Here is a sample of the debug log from the system admin pro email setup module

Apr 12 00:16:07 srv29 postfix/smtp[11568]: 154B240232548: lost connection with alt3.gmail-smtp-in.l.google_com[74.125.141.26] while receiving the initial server greeting
Apr 12 00:17:39 srv29 postfix/qmgr[7031]: DF04C40232581: from=<[email protected]>, size=450, nrcpt=1 (queue active)
Apr 12 00:17:39 srv29 postfix/smtp[14198]: DF04C40232581: host gmail-smtp-in.l.google_com[173.194.78.27] refused to talk to me: 421 service not available (connection refused, too many connections)
Apr 12 00:17:39 srv29 postfix/smtp[14198]: DF04C40232581: host alt1.gmail-smtp-in.l.google_com[64.233.177.27] refused to talk to me: 421 service not available (connection refused, too many connections)
Apr 12 00:17:39 srv29 postfix/smtp[14198]: DF04C40232581: host alt2.gmail-smtp-in.l.google_com[209.85.144.27] refused to talk to me: 421 service not available (connection refused, too many connections)
Apr 12 00:17:39 srv29 postfix/smtp[14198]: DF04C40232581: host alt3.gmail-smtp-in.l.google_com[74.125.141.27] refused to talk to me: 421 service not available (connection refused, too many connections)
Apr 12 00:17:39 srv29 postfix/smtp[14198]: DF04C40232581: to=<[email protected]_com>, relay=alt4.gmail-smtp-in.l.google_com[64.233.186.27]:25, delay=324, delays=323/0.01/0.54/0, dsn=4.0.0, status=deferred (host alt4.gmail-smtp-in.l.google_com[64.233.186.27] refused to talk to me: 421 service not available (connection refused, too many connections))
Apr 12 00:18:15 srv29 postfix/smtp[11568]: 154B240232548: to=<[email protected]_com>, relay=alt4.gmail-smtp-in.l.google_com[64.233.186.26]:25, delay=2394, delays=1757/0.02/637/0, dsn=4.4.2, status=deferred (lost connection with alt4.gmail-smtp-in.l.google_com[64.233.186.26] while receiving the initial server greeting)

Any suggestions as to what I should try? the whole point of paying for this module was to make this easier than editing the postfix files.

thanks,
amcoit

Google can sometimes block too many attempts.

Sign in to your Google account go to signing in options, review the blocked attempts, then click that was me.

Also, see this.

Hi, thanks for the suggestions.
it is definitely NOT google rejecting it because of too many attempts. It was a fresh new account and the error happened beggining on attempt #1 and conitnues until now

I did have a look at the second link you provided. That is more likely the error since from what I can see there are no postfix config files changed by system admin pro.

I could have done that manually to begin with, but since I paid for the module to make life for future people maintaining the system easier, I thought it would be important to debug whats going on.
I will attempt to create the pwd file manually and see what happens.

thanks.

Do you see any email from google about signing in to that account?

Anyhow, if you say it does not work, i believe this is considered a commercial module and you have free support from Sangoma.

Free support for bugs, not config issues. I have just tested using sysadmin 14.0.12.2 and gmail is working just fine for me.

Apr 12 12:55:45 34693894 postfix/pickup[13490]: A2A59181500A8: uid=995 from=<asterisk>
Apr 12 12:55:45 34693894 postfix/cleanup[13586]: A2A59181500A8: message-id=<[email protected]>
Apr 12 12:55:45 34693894 postfix/qmgr[13489]: A2A59181500A8: from=<[email protected]>, size=554, nrcpt=1 (queue active)
Apr 12 12:55:48 34693894 postfix/smtp[13588]: A2A59181500A8: to=<[email protected]>, relay=smtp.gmail.com[173.194.195.108]:587, delay=3.2, delays=0.02/0.13/1/2.1, dsn=2.0.0, status=sent (250 2.0.0 OK 1523548548 192sm1713460ioc.78 - gsmtp)
Apr 12 12:55:48 34693894 postfix/qmgr[13489]: A2A59181500A8: removed

Enabling gmail delivery in System Admin should write out files in /etc/postfix, main.cf, sasl_passwd, and sasl_passwd.db. If those files are not being written, something is preventing that (permissions? incron?).

I found the bug. Pressing Submit on the system admin module does not triggert the Apply Config button so it doesn’t show up.

In fact, I think nothing in system admin pro triggers it, cause I tried timezone and that didnt pop the Apply config button.
After I went to another module (extensions) and made a trivial change, then pressed submit followed by Apply, the postfix main.cf file was updated and the 2 sasl_password files were created (as should have happened)
After this I was able to send email succesfully. This is definitely a bug on the system admin pro module.
thank you for your help, i really appreciate it.
-amcoit

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.