Commercial Endpoint Manager - Not available online


(GSE, LLC) #1
[root@localhost ~]# fwconsole ma --edge upgrade endpoint
Edge repository temporarily enabled
No repos specified, using: [commercial,standard,extended,unsupported] from last GUI settings

endpoint does not exist online, unable to upgrade
Updating Hooks...Done
Chowning directories...Done
Resetting temporarily repository state

Support renewal is current:

Registered Modules

Endpoint Manager

Expiration Date 2039-03-22 (Free Updates until 2021-07-26)

What’s going on here? What other information can I provide to help diagnose?


(Itzik) #2

Is it installed? Do you see it in the GUI?


(GSE, LLC) #3

Yes:

EndPoint Manager 14.0.43.14 Stable Sangoma Technologies Corporation [Commercial] Enabled; Not available online

A small amount of additional background, maybe relevant, maybe not. The system underwent the major upgrade from 10.13.66.whatever to 15.whatever.is.current. Amidst that obviously a great deal of modules were upgraded. PhoneApps was upgraded, but disabled because:

Missing Requirements:

EndPoint Manager module version 15.0.25 or higher is required, you have 14.0.43.14

It’s my understanding from some other stuff I found on the forums that my Cisco phone config files aren’t being generated correctly because PhoneApps is broken.


(Itzik) #4

Seems like you renewed the annual maintenance yesterday or today. Might be that the activation don’t sync. Was Apache restarted? If not, run

service httpd restart

Afterwards, try running

fwconsole sa update

And then

fwconsole ma downloadinstall endpoint --force

(GSE, LLC) #5

All of these things have been tried multiple times over the past day.

FWIW, the downloadinstall error is quite different when done without the “–edge” flag:

[root@localhost ~]# fwconsole ma downloadinstall endpoint --force
No repos specified, using: [commercial,standard,extended,unsupported] from last GUI settings

Downloading module 'endpoint'
The following error(s) occured:
 - Retrieved Module XML Was Empty

Not sure how helpful that is.


(Kapil Gupta) #6

Hi @gsellc Please confirm your endpoint license is active by following command -

cat /etc/sangoma/license-*.zl |grep endpoint

If license is active then may be you can send me direct message with your Deployment ID and “cat /etc/sangoma/pbx-brand” output to check locally.

Thanks
Kapil


(GSE, LLC) #7

Thanks Kapil,

I think the output is pretty unexpected. I’m not sure how to DM using this forum platform… if you can direct me I’m happy to send unsanitized output? For now, here is a sanitized version of the pertinent data:

[root@localhost ~]# cat /etc/sangoma/license-**********.zl | grep endpoint
[root@localhost ~]# cat /etc/sangoma/license-**********.zl
Hardware-Locked = Yes
Product-Name = PBXact
Registered-To = **********
branding = FreePBX
deploy_type = OSS
deployment_id = **********
deploymentid = **********
distributor = No
epm4ucp_exp = 2021-07-26
epm_exp = 2039-03-22
global_lic_exp = 2039-03-22
hostid = **********************
license_version = 2
updates = ******************
Expires = 25-Mar-2030
Produced-By = Schmooze Communications
Verification-Code = **********************************************
[root@localhost ~]# fwconsole sa update
Updating license for **********
Done!
No changes from original Licence.
[root@localhost ~]# cat /etc/sangoma/pbx-brand
FreePBX[root@localhost ~]#

Did I renew the wrong product or something? I noticed that I bought the EPM/UCP thing, totally unnecessary for my deployment, but whatever… then I renewed what I thought was my support for Commercial Endpoint Manager. I’m confused. Thanks for the help.


(Kapil Gupta) #8

Hi @gsellc

As you are using a commercial module so I suggest please raise a support request (https://support.sangoma.com/) to debug further.

Best Regards
Kapil