Commercial Endpoint Manager - Latest Version is Old

Hi there,

I’ve been using the Commercial Endpoint Manager module for a couple of years, and has been working great.
One thing I noticed was that the firmware included in the Endpoint Manager was not up-to-date, so I checked if there were an updates to the module.
The module version installed was, but the latest version available to download was

At that time I guessed that there was something in the latest versions of the module, so it was taken down temporarily.
So I decided to wait for a couple of months but nothing changed; the latest version available was still
I then started to google around and found that there were forum posts that stated that the user is using version of Endpoint Manager.

I tried enabling Edge Mode in advanced settings, applied the change and re-scanned for updates, but nothing changed.
So it looks like the latest version for Endpoint Manager is stuck. However, I am able to update other modules without issues.
Just for reference, the FreePBX Framework version is, and I was also able to see version when I turned on Edge Mode.

Please let me know if you need to check any logs or settings.
Thank you,

Your maintenance period has expired:

Ah, so the 25 years applies to the expiration date and not for updates. I see now.
Thank you very much for your notice.

1 Like

I’ve purchased the renewal for Endpoint Manager, and am seeing the updated expiration date in System Admin, but the version is still stuck at
Do I need to wait for a day or two?


fwconsole ma downloadinstall endpoint

Tried that, and ended up downgrading to
I guess I’ll have to wait.

@Lyute There shouldn’t be any waiting needed, however if after 24 hours you still aren’t seeing a new version, please contact support so we can have someone take a look and see what might be going on.

I checked again today, and the update is now available. Thank you!
Now it seems that the available firmware for polycom phones are still out-of-date, so guess I’ll need to wait for this to come in.

Anyway, the initial problem is solved. :slight_smile:
Thanks again.

You can file afeature request to get this addressed, or you can upload a custom firmware:

OK, I’ve created a feature request and will see what happens.
Thanks again!

1 Like

Polycom is not a certified partner so things like this happen when we do not have items to do for Certified partner phones so you will rarely see Polycom updates of any kind from us as they are basically frozen in time unless a major bug gets introduced in EPM to keep from even doing basic provisioning. Outlined here

I see, that’s understandable since testing each firmware update will take time and money. Guess I’ll have to tackle this by custom firmware upload then.
Thanks for all of the info!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.