Comments starting with '#' error on SIP and IAX Settings pages,

I am getting multiple copies of the following error, once for each #include line in the sip.conf and iax.conf files.

Example, this is from teh SIP Settings page and repeats for sip.conf lines 30, 43, 49, 54, 55, 59, 60 and 69. Similar situation on IAX Settings page.

Deprecated: Comments starting with ‘#’ are deprecated in /etc/asterisk/sip.conf on line 30 in /var/www/asterisk/admin/modules/sipsettings/page.sipsettings.php on line 973

I’m just a user and don’t pretend to be a programmer but did try commenting out the offending sip.conf lines (i.e. ;#include sip_general_custom.conf etc.) but lost all my sip functionality. Everything seems to be working normally. Something went wrong with the conversion scripts? I’ve also gone into a couple of files and changed ‘split’ to ‘explode’ to clear similar errors. I tried to re-install and force the conversions with ./install_amp --force-version 2.5.0

Thank you. That worked. I have submitted the following bug as low priority per your suggestion.

Ticket 4681 (new Bugs)

ahh - I suspect that it may have a very low level of warnings being printed in your php settings.

Your issue is still real but probably harmless.

I suspect the line in question in page.sipsettings.php is:

      $sip_conf = parse_ini_file($file,true);

if that is the case, try changing it to:

      $sip_conf = @parse_ini_file($file,true);

and see if your errors go away. If so, please file a bug report indicating the warnings and this fix so we can get it in. The ‘@’ sign simply tells php not to print out any such warnings like that.