Command to upgrade

What is the CLI command to complete the following EndPoint Manager Upgrade (the upgrade isn’t showing up in module admin)


Thanks in advance for your help.

Something is not right there. I recommend you open a commercial module support ticket so we can see it properly.

Hi Lorne

Is there a cost to opening a ticket?


You can open a commercial module ticket without any support credit.

I’ll give it a try.

I tried to open a ticket, however after completing the form and trying to submit it, I get an error message.


I see what’s going on now. You have let your EPM maintenance lapse so you can’t upgrade, but an upgrade is required to support the Phone Apps module. You can renew the maintenance on your EPM module so that you can upgrade, or disable Phone Apps so you can continue to use the current version.


So who do I talk to about resolving this and is there a cost? I’ve got a bunch of modules that have expired.

You are able to purchase renewals in the portal:

1 Like

Hi Lorne

My system is small and only for home use. I have one Sangoma S500 phone and 6 Yealink cordless phones. If I understand the way the commercial modules work, then I don’t need to purchase and EPM or the Phone Apps module as both are supported on the S500 phone. My Yealink cordless phones aren’t supported under EPM or the Phone Apps module. So, do I go ahead and disable the Phone Apps module to avoid the security threat? If that’s the case then the only modules I’m interested in is the Call Recording Reports and the Voice Mail reports. These I can be purchased via the portal.

Incidentally, I also have a analog FXO / FXS card that was working, stopped working (then remotely corrected by Sangoma - at my expense) and has now stopped working after a module upgrade.

Thanks again for your help.

1 Like

If you are not using any of the paid features of EPM, and don’t intend to, you may wish to open a ticket of type ‘customer service and billing’ and request that your paid EPM license be removed from your deployment. That will allow you to use the free features with your Sangoma device, and also allow you to upgrade to current.


Hi Lorne

Thanks for the info. I’ve reviewed the EPM Supported Devices page and I noticed that the Yealink W60B (DECT Base station) is supported however the cordless phones aren’t (W-56H) only W52P & W56P; What’s the difference between cordless phones?
EPM - Supported devices

Removing the EPM license is an option and it will only effect the Yealink phones. Will the W-56H be supported in the near future? If so then it might make more sense to continue with the EPM and Phone Apps license. What do you think?


Question for the manufacturer, unless someone here is familiar with both models.

Also a question for the manufacturer.

I can’t offer advice beyond stating what you already know. Maximum flexibility is to pay for the renewal, maximum economy is to abandon restapps and continue to use the old EPM.

Thanks Lorne

If the Yealink decides to support the W-56H in the future, can I re-implement the EPM & Rest Apps licensees at a future date.

If by ‘re-implement’ you mean will you be able to purchase a license and/or renewal in the future, then yes.

Hi Lorne

Okay. I need to ask again so that I have it clear in my mind.

1.) I’m going to create a ticket type ‘customer service and billing’ request that my paid EPM license be removed from your deployment.
2.) What do I do with the Restapps module; disable it or upgrade it (even thought I can’t use it, can it still be upgraded?
3.) I’d like to keep the call recording reporting & VM reports module, so these I would pay for via the Sangoma portal.
4.) All other modules (that I once had) I’ll continue to upgrade them, however they can’t be used?


  1. okay
  2. one you abandon your paid license, both restapps and epm can be upgraded to current.
  3. okay
  4. Once you purchase a 25 year license, you can continue to use that version of the module for 25 years. Maintenance renewal entitles you to module upgrades and support.

Hi Lorne

A quick update.

  • The Rest Apps is not not showing a security alert and has updated to the latest version.
  • I can’t seem to update the Sangoma ticket.
  • EPM isn’t working. I tried to use it to access my S500 set but couldn’t. I thought that EPM could still be used to access any Sangoma phone?

Thanks in advance for your help.

Hi Lorne

Sorry I forgot to add a screen shot of EPM when I try and access it.

Permissions issues are almost always resolved with

fwconsole chown
1 Like