CNAM to show for incoming PRI calls

Hi I am trying to get some help to get the incoming CNAM to show. I am using FreePBX 2.8.0.4 with Asterisk 1.6.2.15, DAHDI 2.4 and Digium TE121 card. complete install was using AsteriskNow. We currently do recieve CNAM on our PRI.

I did a trace of an incoming call over the PRI circuit:

– Executing [[email protected]:18] NoOp(“DAHDI/1-1”, “Using CallerID “LA:8187958811” <8187958811>”) in new stack

I found this article below, but I am not sure where to add it… yes I am still a newbie, but learning fast!!

On ISDN PRI lines (US NI-2 type) Callerid name information CNAM is transmitted in a separate FACILITY IE. some time AFTER the initial SETUP message. If you are using CNAM in your dialplan make sure to insert a wait statement before using the calleridname variable. Otherwise CALLERIDNAME will not be populated initially.

i.e.:
exten => _X.,1,NoOp,${CALLERIDNAME} ; will be empty. - FACILITY IE has not been received yet.
exten => _X.,2,Wait(1) ; wait for the CO to find the name in the database
exten => _X.,3,NoOp,${CALLERIDNAME} ; now it shows the name

I have been annoyed by the same intermittent caller id info on our PRI.

I’ve tried several things with absolutely no effect whatsoever:

  • immediate=no in dahdi_chan.conf did nothing, and I belive this is only for analog lines anyway.

  • sendcalleridafter=0/1/2 in dahdi_chan.conf had no effect also. From what I was reading that was the whole purpose for that setting, but no love…

  • extensions_custom.conf
    [from-pstn-custom]
    exten => s,1,Wait(2)

Seemed to be better at first, but no. It may come through 5 or 6 times in a row and then fail 4 times, then work once, then fail twice - there’s no pattern, it’s just a race condition in there somewhere. :frowning:

Other bits of info on our setup in case they are helpful:
We’re using a Redfone FoneBridge2.
Asterisk 1.8
FreePBX 2.9
AT&T PRI