Cluster is not configured on other node

hello. i’m getting this error while trying to join node B to the cluster. here is the image and pcs status. What do i need to do to fix this ?

[[email protected] ~]# pcs status
Cluster name: freepbx-ha
Last updated: Tue Apr 12 10:34:35 2016
Last change: Tue Apr 12 09:23:19 2016
Stack: cman
Current DC: freepbx-a - partition WITHOUT quorum
Version: 1.1.11-97629de
2 Nodes configured
20 Resources configured


Online: [ freepbx-a ]
OFFLINE: [ freepbx-b ]

Full list of resources:

 spare_ip	(ocf::heartbeat:IPaddr2):	Started freepbx-a 
 floating_ip	(ocf::heartbeat:IPaddr2):	Started freepbx-a 
 Master/Slave Set: ms-asterisk [drbd_asterisk]
     Masters: [ freepbx-a ]
     Stopped: [ freepbx-b ]
 Master/Slave Set: ms-mysql [drbd_mysql]
     Masters: [ freepbx-a ]
     Stopped: [ freepbx-b ]
 Master/Slave Set: ms-httpd [drbd_httpd]
     Masters: [ freepbx-a ]
     Stopped: [ freepbx-b ]
 Master/Slave Set: ms-spare [drbd_spare]
     Masters: [ freepbx-a ]
     Stopped: [ freepbx-b ]
 spare_fs	(ocf::heartbeat:Filesystem):	Started freepbx-a 
 Resource Group: mysql
     mysql_fs	(ocf::heartbeat:Filesystem):	Started freepbx-a 
     mysql_ip	(ocf::heartbeat:IPaddr2):	Started freepbx-a 
     mysql_service	(ocf::heartbeat:mysql):	Started freepbx-a 
 Resource Group: asterisk
     asterisk_fs	(ocf::heartbeat:Filesystem):	Started freepbx-a 
     asterisk_ip	(ocf::heartbeat:IPaddr2):	Started freepbx-a 
     asterisk_service	(ocf::heartbeat:freepbx):	Started freepbx-a 
 Resource Group: httpd
     httpd_fs	(ocf::heartbeat:Filesystem):	Started freepbx-a 
     httpd_ip	(ocf::heartbeat:IPaddr2):	Started freepbx-a 
     httpd_service	(ocf::heartbeat:apache):	Started freepbx-a 

[[email protected] ~]# 

Hello,

I was wondering if you found any solution for your problem.

This appears to be a bug in new installs of HA, I’ll be investigating it today.

Yep, it was. I’ve published HA version 13.0.9.1. You just need to upgrade that on your production machine, and then run a cluster check. That will error (because the second node isn’t there), but you will then be able to join.

Sorry about that!

Still getting the same message and I did update FreePBX HA, rebooted Node A and did a cluster check (Manage->Cluster->Run)

fwconsole ma list | grep freepbx_ha | freepbx_ha | 13.0.9.1 | Enabled |
When I try to join nodeB i get the same error message.

the ‘Cluster is not configured on other node { status: firstboot }’ error? Or the insufficient disk space error, or both?

Checking that the other node is configured. Cluster is not configured on other node - {"value":"firstview","0":"firstview"} Check for available disk space Insufficient disk space (Run 'Verify' on other node)

Both errors

Sorry, typo. 13.0.9.2.

Yeap. It works now and syncing started.

Thank you for your help :slight_smile:

1 Like