Client denied by server configuration: /var/www/html/admin/


#1

I have googled this to death and tried all kinds of troubleshooting.

Results in no changes.

I did a clean install of the newest FreePBX and processed all the updates.

I then did a restore of my most recent install which was only a few days ago.
Once the reload was done I started getting this error

I am now getting the message in the subject. The httpd error_log reports “client denied by server configuration: /var/www/html/admin/”

I have gone over everything many times, the install setup, the folder permissons, password, etc.

NOTHING has worked.

Any thing else I am missing?

Thanks


#2

You mean NOBODY knows? I cleared the OS off the drive and started again over following the instructions at : http://www.freepbx.org/support/documentation/installation/install-process-for-centos-5-1

Yet, now for a CLEAN install I am getting the same result. Looks like a bug report to me.


(Philippe Lindheimer) #3

You have provide very little data to go by, in addition it has been only one day from when you posted your post. So it is not surprising that there have been no responses other than no one else who has read this has seen the same issue.

As a result, there is not enough data to post a bug report either so you would be best to try and provide more info, or get a hold of a pre-built ISO that installs FreePBX and includes all the needed dependencies.


#4

Geekyboy,

there is a 99.99% chance that you missed something. Either you didn’t follow all of he directions EXACTLY, or did something extra, or changed something because you felt that you wanted something different.

It’s bound to be either a permissions problem or you tweaked the httpd.conf file.

Apache and asterisk are running as the asterisk user correct?


#5

What is it with the open source community and the arrogant attitude of:

“If you can’t install my software correctly, it’s because you’re stupid”

Real people do not know the ins and outs of someone else’s software, and also have a time and patience limit. So many FOSS installation procedures seem to be oblivious to this real-life fact, and so is FreePBX.

I think it’s a bit rich to blame someone for “missing something” considering the installation instructions file contains the following:

"THESE INSTRUCTIONS ARE OUTDATED!!! (JULY, 2008)
PLEASE VISIT: http://www.freepbx.org/support/documentation/installation "

where that web page’s instructions stop at “./install_amp” (which precedes the point where the OPs problem actually arose), with the page then pointing you to a forum full of fragmented instructions and half-answered threads.

I ran into the same problems today as the OP. The only log file containing anything showing an error was the apache2.log, The solution was:

  1. add the apache2 user (www-data), to the “asterisk” group
  2. chmod the FreePBX folder to allow reading and execution to group members
  3. restart Apache2 & Asterisk
  4. The FreePBX index should now work. You may need to fix any further issues thrown up by the Status page.

The alternative suggested by the forums was to only use Apache2 to run the FreePBX site and nothing else and run apache2 as user “asterisk”. Sadly, this is the real world and I need to run several sites on that server!

If anyone from the FOSS community ever reads this, as I have said on many threads across the web in my years of using open-source…

If you want your work to be widely used and appreciated:
a) please think about user-friendliness when you write an installer
b) not everyone has exactly the same setup / distro / knowledge / patience as you, it is your responsibility as software creator to account for this and write in safety-nets
c) UPDATE YOUR F##KING DOCUMENTATION!!! “This is outdated, please visit” is not good enough!
d) When someone runs into trouble with your package, consider the possibility that a contributing factor is one or more of: bad documentation, broken installer, inappropriate instructions; rather than pure user incompetence. You are probably partly to blame for the difficulties people are having. Sorry, but it’s true.


(system) closed #6