Cisco SPA514G Keys Not Recognized

New to FreePBX, and am trying to set it up with Cisco SPA514G phones. Installed FreePBX from the ISO on it’s own dedicated machine. Don’t have any trunk lines - just wanted to set this up internally for testing. I’ve gotten to the point where I’ve created extensions, and enabled voicemail. Went to go setup voicemail and get the prompt to “enter your name and press #”. I press the # button but the system does not recognize it. Played around with other menus as well, i.e. accessing voice mail where you can press keys 2, 0, *, # etc and pressing the keys does not register with the system. Not sure at this point why the keys aren’t working - any pointers would be appreciated!

Check the phone’s dial plan.

Possibly, there is an issue with codec negotiation. In the phone web interface:
Admin Login > advanced > Voice >Ext_n. Under Audio Configuration, try setting DTMF Tx Method to InBand. If no luck, try AVT.

I tried InBand and AVT with no luck. Then I tried INFO and it worked! Thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.