Cisco SPA112, FreePBX v2.10.0

Hello everyone,
I am attempting to set up a Cisco SPA112 to work with our FreePBX system for faxing. I cannot find ANY documentation anywhere on how I should set this thing up - do you set it up as an extension, do you create a SIP trunk for it, how does it work? Cisco is about useless in the docs, and I can’t find anythign online other than “It works great”. Can anyone help?

So backing down the baud rate on the fax machine to 9600 and was able to recieve a fax, but still can’t send ; I’m experiencing some stuttering/choppiness in calls also. I’m guessing my best bet to implement QoS, even though we have like 25Mbps down/2Mbps up.

Set up and extension on the FreePBX system.

Configure the SPA112. There are only a few things that need to be configured to get it to connect. IP address of the server, user name and password.

That’s what I keep reading. The problem is, I’ve never seen anywhere in freepbx to set a username for an extension, unless I’m missing something painfully obvious; I’ve only ever used that for SIP trunking. I’m used to setting up a polycom, where I create a config file in the tftp with the MAC of the phone and a config file for the phone/extension in the same folder. What am I missing?

Sorry, I guess user name is not the best way to describe it. I am so used to editing Polycom configs where the auth.userId is the extension.

You set it up as an extension. If you come off hook and dial **** and then 110# (you will be prompted) it will read you the IP and you can just web browse to it.

Username/Extension/authuser The way FreePBX creates extension they are all the same thing. Secret = password.

A trunk and an extension are the same thing by the way. Trunks just expose all the variables to you.

Well that makes a lot of sense. I kinda feel dumb overlooking that haha. I’ll give it a shot and let you know how it goes. Thanks for the help.

Just an update - that worked beautifully as far as registering the extension w/Asterisk ; I can use it. However, I can’t fax at all across it. It tries & tries to negotiate, then finally errors out. I’ve turned off jitter control in the SPA112 and made the other changes noted here:
http://docs.voipswitch.com:18081/display/doc/Cisco+SPA112+Fax+configuration

Anything else I should do?

We setup a virtual ext 130 and in the section This device uses custom technology.Dial we wrote SIP/[email protected] of ATA

Then under Trunks
created a sip trunk for fax in incoming settings
host=IP ADDRESS of ATA
type=friend
context=from-internal

Hope this helps

Both of you need to state FreePBX and Asterisk versions. t.38 needs to be configured on the spa-112 and on Asterisk.

Make sure your phone lines are t.38 capable.

if you are faxing in/out over a sip trunk it is a hit or miss proposition. you might want to check with your sip provider before spending a lot of time on this.