Cisco SPA112 Fails to Register on FreePBX 13


I have FreePBX 13.0.124 installed and working with a number of Yealink and soft phones.

I’ve purchased a new Cisco SPA112 and upgraded the firmware to 1.4.1(002) as the previous one did not work either.

According to the SPA112 it fails to register with freePBX but on the FreePBX dashboard it says the SPA112 is online but you can’t call the SPA112 extension.

I used the Quick setup screen on the SPA112 and set Proxy, Display Name, User ID and Password. And I have changed the standard 5060 port to another for security reasons.

The SPA112 extension is configured for pjsip. I’ve tried channel_sip but the FreePBX never shows it online.

Has anyone got the SPA112 to successfully register with FreePBX ? Are there any other settings that need to be change for it to register properly ?



Reset the port back to 5060, wait for the SPA112 to call for registration, On pjsip only register when called for by the device. My first setup has like 60 SPA112, they all registered with Chan PJsip and work great. If you want to you could change port later see what happens, the default Listen port setting is in (Setting>Astrisk sip Setting> PJsip) “Port to Listen On = 5060” Good luck


I have reset the SPA112 back to 5060 and it does register and work.

However I’ve been unsuccessful at getting the SPA112 to work with other ports.

I will just have to leave it at 5060 for the present.

Thanks for the help.



Hi … I tried setting to different port .It worked if I only did it in the SAP112 not make any changes in freepbx… All of my SAP112 are set to pjsip. Have you set the Setting>Asterisk sip setting>Chan pjsip setting the last two lines (External IP Address ip.ip.ip.ip) (Local network 192.168.xx.0/24)

Sorry about the typo error “SPA112” I do have about 60 SPA112 in my last setup. .Now on random ports