Cisco gateway

Hi, I’m trying to setup a Cisco 1751v router as a gateway to connect my [email protected] 2.7 box to the analog telephone line to make and receive calls.
This router has got 1 ethernet interface and 2fxo interfaces.
I wanted to connect 1 of these to the phone line and another one to an analog phone, but i’don’t know absolutely how to configure this router to make it work this way.
Anybody can help me and post a sample configuration file please?

Current configuration of the router is:

System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright © 2003 by cisco Systems, Inc.
C1700 platform with 98304 Kbytes of main memory

Current configuration : 758 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SipGateway
!
boot-start-marker
boot-end-marker
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
voice-card 1
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
!
interface FastEthernet0/0
ip address 10.1.6.39 255.255.255.0
speed auto
!
ip classless
no ip http server
!
!
!
control-plane
!
!
voice-port 1/0
!
voice-port 1/1
!
!
gateway
timer receive-rtp 1200
!
sip-ua
retry invite 1
retry response 3
retry bye 3
retry cancel 3
retry register 3
timers trying 1000
sip-server ipv4:10.1.6.200
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

I only added last part (gateway ans sip-au) to the default router configuration, but i’m not sure if it’s correct or not.
Also i’m not sure how to setup trunks and incoming-outgoing routes on asterisk.

Thanks for your help.
Best regards

This should be helpful:

http://vt100.at/?site=doc/105

If it works with 2800 series should work with 1700 series as well. Maybe
a bit different though.

And no I havent tried it yet.

Regards,
Kerem

Archy79 wrote:

[quote]Hi, I’m trying to setup a Cisco 1751v router as a gateway to connect my [email protected] 2.7 box to the analog telephone line to make and receive calls.
This router has got 1 ethernet interface and 2fxo interfaces.
I wanted to connect 1 of these to the phone line and another one to an analog phone, but i’don’t know absolutely how to configure this router to make it work this way.
Anybody can help me and post a sample configuration file please?

Current configuration of the router is:

System Bootstrap, Version 12.2(7r)XM2, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright © 2003 by cisco Systems, Inc.
C1700 platform with 98304 Kbytes of main memory

Current configuration : 758 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SipGateway
!
boot-start-marker
boot-end-marker
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
voice-card 1
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
!
interface FastEthernet0/0
ip address 10.1.6.39 255.255.255.0
speed auto
!
ip classless
no ip http server
!
!
!
control-plane
!
!
voice-port 1/0
!
voice-port 1/1
!
!
gateway
timer receive-rtp 1200
!
sip-ua
retry invite 1
retry response 3
retry bye 3
retry cancel 3
retry register 3
timers trying 1000
sip-server ipv4:10.1.6.200
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

I only added last part (gateway ans sip-au) to the default router configuration, but i’m not sure if it’s correct or not.
Also i’m not sure how to setup trunks and incoming-outgoing routes on asterisk.

Thanks for your help.
Best regards


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

[/quote]


Amportal-users mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/amportal-users

Post generated using Mail2Forum (http://www.mail2forum.com)

I could make the gateway work. I used this configuration:

Current configuration : 1187 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SipGateway
!
boot-start-marker
boot-end-marker
!
!
clock timezone GMT 1
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
voice-card 1
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
!

!
interface FastEthernet0/0
ip address 10.1.6.39 255.255.255.0
speed auto
!
ip classless
no ip http server
!
!
!
!
!
control-plane
!
!
voice-port 1/0
input gain 10
output attenuation 10
no comfort-noise
cptone IT
connection plar 101
!
voice-port 1/1
!
!
!
!
!
dial-peer voice 2 voip
destination-pattern 1…
session protocol sipv2
session target ipv4:10.1.6.200:5060
session transport udp
dtmf-relay rtp-nte
codec g711ulaw
no vad
!
dial-peer voice 100 pots
destination-pattern 0…
port 1/0
forward-digits all
!
gateway
timer receive-rtp 1200
!
sip-ua
retry invite 1
retry response 3
retry bye 3
retry cancel 3
retry register 3
timers trying 1000
sip-server ipv4:10.1.6.200
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

Now i only have a problem with hangup. After that i use for example Ivr the fxo doesn’t hang up immediately so line remain busy for a long time.
I don’t know how to set that in Asterisk…

What would the FreePBX config look like in this scenario? I am wanting to do something similar. I have a Cisco Voice Gateway and I would like it to pass everything off to Asterisk. Phones would connect to the FreePBX box and it would route calls out through the Cisco Gateway.

Thanks