Cisco CP7975G Registration EPM

I am not able to get my CP7975G phone to register with FreePBX. It is running the stable 8-5-4S firmware. I have tried with a manual config multiple times, and after that not working (stuck on registering), I tried with the commercial EPM (which states it will work if I have the SIP firmware, which I do due to a smartnet agreement with Cisco). With the EPM, I am still stuck on registering. Does anyone have any tips or ideas to get this working? Thanks!

Could you please post the sip output for the phone ?
you would get that from “sip set debug on” in the asterisk cli.


I just ran sip set debug on, and it said SIP debugging was on. I looked through the log (I assume this is where it would be), and there is nothing for that extension at all.

Hey Jerry,

If that is the case, the phone does not even know about the SIP server.
Did you configure the Phone with the IP address for the Asterisk server ?

Thank You


That’s strange because I have option 150 set up in DHCP and it looks for the configuration, and in the config it is set up by freepbx commercial EPM.

Hi Jerry,

Then i am not sure if the config is downloaded to the phones or not.

That’s what it seems like to me, too. But when I look under phone info, the name of the file is there, and the provisioning server is correct. I am stuck!

Hi Jerry,

Can you post the config for your 7975G? I have a 7975G that I have working. Along with 3 7970s and 2 7960s. So they do work.



Try going to the phone Web GUI and under “Console Dumps” download the files and search for “Parser”

If you find it, it will tell you “XML Parser Error” and tell you what line its config file that it doesn’t like.

I have a 7965 on the latest firmware, ver 9. I will post the config for that, and the config for my 7970 phone on 8-5-4 firmware.

You can try my 8-5-4 config and see if that works, else you could try upgrading firmware and trying my ver 9 config, but firmware upgrading/downgrading can be a monster

Working 7970 config on 8-5-4S:

<?xml version="1.0" encoding="UTF-8"?>



                        <timeZone>Pacific Standard/Daylight Time</timeZone>

           <member priority="0">




















         <phoneLabel>Klemz Home</phoneLabel>
        <line button="1">





Make sure your secret is not exceeding what Cisco phones can use. Try going to the extension and reducing the length of the secret by exactly one character, and one character only.

1 Like

Oh, one more thing. I had more troubles again tonight with another Cisco 7945G. For the Extension, make sure NAT = Never

Don’t ask why, but it works.

Don’t count on me ever recommending Cisco phones with Asterisk. Cisco is Cisco and Cisco works with Cisco. LOL!

1 Like

The Cisco SPA series is actually great with FreePBX, good quality phones, low cost, actual SIP working on latest firmwares, easy to configure using HTTP or XML.

my favorite model is the SPA514G because it is the only SPA with gig ethernet + PoE.

Also, if you call Cisco for support, they only will support the 7940, 7960 and SPA phones for 3rd party (asterisk) integration.

I also would never recommend a new freepbx rollout with cisco 79xx phones tho!

1 Like

Reilly, I will have to give the Cisco SPA series a good look. I got a few Cisco 7945s donated to me, and I am sure the work great with CUCM and Skinny protocol. I knew right from the get-go I would have to burn the SIP firmware on these. I grumbled about having to make available an TFTP (even though it is built in to FreePBX), but had to add the Option 66 to point to it.

I guess once you get it setup, and you know the ins and outs of the 7945G, it is not a big deal. It is just amazing that all the information that I needed to set these babies up was not in one place, but in about a dozen little corners of the internet. Google certainly is our friend.

When you say specifically the 7940, 7960 (and SPA) are supported for 3rd party call managers, I wonder what makes the 7940 and 7960 so special. Those models sounds like they are Cisco CUCM intended models. I can understand the SPA series being right out compatible. Cisco wanting to get in the SIP game across the board, regardless of the Call Manager, I can understand that.

Thanks again for your experience.

Guys, sorry I was out of town when you posted this. Anyway, I am back in the office today, and I tried getting the phone to register with a combination of all of these tips, and it finally worked! I tried shortening the secret and that didn’t seem to work, but then I set NAT to never and with the short secret it worked. What is the max length for a secret, does anyone know? Still strange that the NAT has to be set to never, but anyways, I think this is what made it work.

1 Like

Hi Jeff,

I see you and Reilly both have the Cisco 7960 & 7970 respectively. I bought 4 in total of these phones, 7960 & 7970 about a year ago and I still haven’t figured out how to provision and install it. My attempts have proved futile as there are so many firmware to choose from.
I would be grateful if anyone could come my aid to help get the phones to work, even for a fee, please. Thanks in advance.


Hi Ed,

Happy to help. We’ll start with the easy part first. What firmware are the 7960 and 7970’s on? Do they try to register?