Cisco 7975G not acting as expected with screen timeouts


#1

I have a Cisco 7975G setup with SIP firmware and registered with Asterisk. So now I am just tweaking the XML setup for my use using this site: http://usecallmanager.nz/sepmac-cnf-xml.html

So far so good, but I am having an odd thing happen with the screen timeouts you can set. I have them configured like this:

 <daysDisplayNotActive></daysDisplayNotActive>
 <displayOnTime>06:00</displayOnTime>
 <displayOnDuration>17:00</displayOnDuration>
 <displayIdleTimeout>00:10</displayIdleTimeout>
 <displayOnWhenIncomingCall>1</displayOnWhenIncomingCall>
 <backlightOnTime></backlightOnTime>
 <backlightOnDuration></backlightOnDuration>
 <backlightIdleTimeout>00:10</backlightIdleTimeout>
 <backlightOnWhenIncomingCall>1</backlightOnWhenIncomingCall>

The active display settings seem to work fine, however when they kick in any calls to the extension are immediately sent to voicemail. You can, however, pickup the phone and make a call with no problem.

And then there is the backlight settings here, they don’t seem to do anything.

My goal here is to basically have the screen on for most of the day, but have the backlight turn off after being idle for 20 minutes, but otherwise the phone should work as it usually does and not kick calls to voicemail after the screen is turned off.

Is this the expected behaviour? If so, then why is there an option to turn on the screen when a call comes in?


#2

Update on this. When the screen comes back on, the phone still pushes everything directly to voicemail. So in essence as soon as the phone goes to sleep it will no longer ring when someone dials it’s extension and you have to reboot the phone to get it to work again. Dialing out from the phone works just fine and asterisk shows it as available.

Has anyone else run into this with this phone?


(Tom Ray) #3

The phone not answering calls has nothing to do with the screen being lit or not. The phone not answering calls but making calls is an issue with the PBX not being able to get replies back from the phone for the keep-alives it is sending.

Is this phone remote the the PBX?


#4

Try a short registration interval:
<timerRegisterExpires>120</timerRegisterExpires>

If no luck, report whether the phone can receive a call immediately after it has made one. Describe network (routers, firewalls, etc.) between phone and PBX.


#5

Thanks for the replies!

@BlazeStudios - The phone is not remote, it’s on the same network and subnet. The screen blanking has something to do with it, as the problem only kicks in when the screen blanks, though this might be co-incidental?? I have it set to come on at 6am and turn off at 11pm. During those hours it all works fine, but as soon as 23h00 hits, you can no longer receive calls until you restart the phone.

@Stewart1 I just dropped the reg down to 600 seconds, but before applying the new setting and restarting the phone I tried placing call from it (worked), then immidiatley dialed it from another local phone, same result, straight to VM. Keep in mind that once 23h00 hits and the screen is turned off then incoming calls do not work at all until the phone is restarted, be that 1 hour or 20.

Also before I rebooted the phone, I ran asterisk in verbose mode and tried to call the extension, here is the output: https://pastebin.freepbx.org/view/19a29639

I am not adept at reading Asterisk logs, but I think this indicates the phone is being reported as busy?


#6

Well I take that back, rebooting the phone did not fix it. The issue persists after a soft and a hard reset. The phone can make calls, but cannot receive them.

Here is the current phone config: https://pastebin.freepbx.org/view/1276fff6


#7

Asterisk indeed decided that the phone was ‘busy’ and didn’t even attempt to call it, though I don’t know why.

What does Reports->Asterisk Info show on the Peers tab for the extension?
Was anything logged shortly after 23:00 (e.g. going unreachable or unregistered, contact removed, etc.)?
What does the main Applications->Extensions page show in the check boxes for the extension? I’d expect CW to be checked and the others all unchecked?

At the Asterisk command prompt, type
pjsip set logger on
which will cause all SIP traffic to appear on the console and in the regular Asterisk log. You should see OPTIONS requests (for qualify) going out to the phone every minute and responses coming back. Also REGISTER requests from the phone every 5 to 10 minutes and responses from the PBX. Do those look normal?


#8

The issue turned out to be DND enabled for the extension via the UCP. Not sure when the got toggled to be honest, and I have no idea why I thought to check it.

Now I feel like an idiot, but I am wondering why that was not logged by asterisk. It strikes me as something a user would do quite easily.

EDIT: For future people reading this. The default DND enable it *78, disable is *79 and toggle is *76. I am not sure how, but I might have dialed one of those by accident.


(system) closed #9

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.