Cisco 7962G wont register to FreePBX

Hello, I’m having a very frustrating issue getting my new 7962G phones to register to my FreePBX Distro. Phone boots up, appears to pull down the SEPmac.cnf.xml file, loads, then hangs at registering. I’m unable to make/recieve calls from these phones.

Originally, I thought I had a TFTP server issue, because I was unable to see the phone getting any files from the server. Running nmap -sU localhost didn’t list port 69 as being open. I messed with iptables and ultimately shut the firewall off for now, but nmap still doesn’t show port 69 being open. I still couldn’t use WinSCP to access the server, saying “Server actively refused connection”, so I began investigating xinetd and the conf files. According to all the info I can find, everything is as it should be. I’ll post the conf files here at the end of the post.

So finally I learned how to do a tcpdump -vv src 10.0.0.71 && dest port 5060 and watched for traffic from my phone. There were registration attempts from the phone, and some replies. I made sure the logins/passwords were correct in the SEPmac.cnf.xml file and kept trying. No luck.

Randomly I decided to try accessing the system through the softphone on my android. Interestingly enough, it registered and worked just fine on tcp. When I changed it to use udp, it quit and said “Could not register with server 10.0.0.10 because the peer actively refused it.” I don’t know what that means, but i’ll guess that’s a big part of my problem.

FreePBX Firmware: 4.211.64-7 Asterisk Version: 11.7.0 7962G Versions Load File: *term62.default* App Load ID: jar42sip.9-3-1ES26.sbn JVM Load ID: cvm42sip.9-3-1ES26.sbn OS Load ID: cnu42.9-3-1ES26.sbn Boot Load ID: tnp62.8-3-1-21a.bin [[email protected] ~]# tcpdump -vv src 10.0.0.71 && dst port 5060 tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes 18:27:32.486453 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 10.0.0.71 tell 10.0.0.71, length 46 18:27:32.486582 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 10.0.0.1 tell 10.0.0.71, length 46 18:27:32.497817 IP (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 576) 10.0.0.71.bootpc > 255.255.255.255.bootps: [no cksum] BOOTP/DHCP, Request from 00:24:c4:44:72:d3 (oui Unknown), length 548, xid 0x9b5, Flags [Broadcast] (0x8000) Client-Ethernet-Address 00:24:c4:44:72:d3 (oui Unknown) Vendor-rfc1048 Extensions Magic Cookie 0x63825363 DHCP-Message Option 53, length 1: Request Client-ID Option 61, length 7: ether 00:24:c4:44:72:d3 Hostname Option 12, length 15: "SEP0024C44472D3" Vendor-Class Option 60, length 38: "Cisco Systems, Inc. IP Phone CP-7962G^@" Requested-IP Option 50, length 4: 10.0.0.71 Parameter-Request Option 55, length 7: Subnet-Mask, TFTP, Domain-Name-Server, Default-Gateway Domain-Name, Option 150, AT 18:27:32.545088 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 10.0.0.71 tell 10.0.0.71, length 46 18:27:32.545218 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 10.0.0.1 tell 10.0.0.71, length 46 18:27:53.613806 ARP, Ethernet (len 6), IPv4 (len 4), Request who-has 10.0.0.10 tell 10.0.0.71, length 46 18:27:53.614061 IP (tos 0x0, ttl 64, id 1, offset 0, flags [none], proto TCP (6), length 44) 10.0.0.71.52168 > 10.0.0.10.6970: Flags [S], cksum 0x4307 (correct), seq 1777979466, win 8192, options [mss 1340], length 0 18:27:53.663276 IP (tos 0x0, ttl 64, id 2, offset 0, flags [none], proto UDP (17), length 59) 10.0.0.71.50253 > 10.0.0.10.tftp: [udp sum ok] 31 RRQ "CTLSEP0024C44472D3.tlv" octet 18:27:57.882064 IP (tos 0x0, ttl 64, id 3, offset 0, flags [none], proto TCP (6), length 44) 10.0.0.71.52478 > 10.0.0.10.6970: Flags [S], cksum 0x6903 (correct), seq 1471920982, win 8192, options [mss 1340], length 0 18:27:57.921492 IP (tos 0x0, ttl 64, id 4, offset 0, flags [none], proto UDP (17), length 60) 10.0.0.71.49511 > 10.0.0.10.tftp: [udp sum ok] 32 RRQ "SEP0024C44472D3.cnf.xml" octet 18:27:58.613457 ARP, Ethernet (len 6), IPv4 (len 4), Reply 10.0.0.71 is-at 00:24:c4:44:72:d3 (oui Unknown), length 46 18:28:07.103549 IP (tos 0x0, ttl 64, id 5, offset 0, flags [none], proto TCP (6), length 44) 10.0.0.71.50870 > 10.0.0.10.6970: Flags [S], cksum 0x5514 (correct), seq 9907378, win 8192, options [mss 1340], length 0 18:28:07.173178 IP (tos 0x0, ttl 64, id 6, offset 0, flags [none], proto UDP (17), length 49) 10.0.0.71.50669 > 10.0.0.10.tftp: [udp sum ok] 21 RRQ "dialplan.xml" octet That's as far as it ever gets. It times out and the phone just sits there.

Here’s the TFTP Config:

[[email protected] ~]# cat /etc/xinetd.d/tftp

default: off

description: The tftp server serves files using the trivial file transfer \

protocol. The tftp protocol is often used to boot diskless \

workstations, download configuration files to network-aware printers, \

and to start the installation process for some operating systems.

service tftp
{
disable = no
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -s /tftpboot -V
per_source = 11
cps = 100 2
flags = IPv4
}

SEP0024C44472D3.cnf.xml

<?xml version="1.0" encoding="utf-8"?> SIP admin *********** 2 M/D/Y Central Standard Time 0.pool.ntp.org Unicast 5060 1 false true false false 101 3 avt false false 3 Main VM 1 false 15000 10 false 10000 20000 5060 184 0 dialplan-0024C44472D3.xml 5060 5060 5060 true true x-cisco-serviceuri-cfwdall x-cisco-serviceuri-pickup x-cisco-serviceuri-opickup x-cisco-serviceuri-gpickup x-cisco-serviceuri-meetme x-cisco-serviceuri-abbrdial false 2 true true 2 2 1 true 6 10 180 3600 5 120 120 5 500 4000 70 true None 9 200 USECALLMANAGER 5060 200 200 3 200 *********** false 3 *97 4 5 200 9 300 USECALLMANAGER 5060 300 Main VM 300 3 300 *********** false 3 *97 4 5 300 9 400 USECALLMANAGER 5060 400 Paging 400 3 400 *********** false 3 *97 4 5 3 false 3 *97 4 5 3 false 3 *97 4 5 3 false 3 *97 4 5 3 false 3 *97 4 5 3 false 3 *97 4 5 3 false 3 *97 4 5 3 false 3 *97 4 5 true 2 false false 0 1 0 0 1 0 1 1,2,3,4,5,6,7 00:00 00:00 00:00 1 English_United_States en_US 1.0.0.0-1 iso-8859-1 1.0.0.0-1 3804

dialplan.xml

I hope i’ve provided enough info for you to help me out on this one… I’m lost. If you need anything else, let me know what and where to find it and i’ll get it up here as quick as I can. If you spot any errors, please help me correct them, as I’m relatively new to this.

Thank you!

In network setting release DHCP Address Released > Yes save and and again DHCP Address Released > No.

Check TFTP server, if pointing correctly bail out if no then set Alternate TFTP Yes and edit TFTP address to your server

Regards
Abhi

For the cisco phones, try setting nat=no on the extension/device side.

nat=no on the phones. I released the IP, and rebooted, but nothing changed. Alternate TFTP=yes and it’s pointing to my server. still hanging at registering.

I should clarify I set release ip=yes, saved, then release ip=no, then saved. nothing happened so i rebooted. Figured I should probably rephrase that.

I did a little more playing, but I still can’t make it work… any more ideas?

I hate to beat a dead horse here, but I’m still lost on this one. Any advice you can offer is appreciated.

Ok, so the new forum style won’t let me fix the configs being displayed incorrectly. all of the code tags are ignored. Anybody know how to fix this? I tried and failed. As you can see above, the SEP file and the dialplan.xml files are seriously screwed up. Really helpful… Now instead of getting help with the original issue, I have to troubleshoot 10 more problems just to get the damn configs to display properly on the forum so I can get an answer…

I am still having this issue and I am still stumped. I hate to rehash this topic but I am still hoping to find an answer.

try loading the phone using http instead of tftp and see what happens.

RESOLVED!

Thanks for the advice! I managed to figure out there were a few things causing my issues. We recently deployed a Windows DHCP Server, and some things like option 66 weren’t properly configured. After a lot of trial and error and some cuss words I finally (after 8 months of blindly clicking around) found the root of my issue. I discovered I had a problem with NAT. In my deployment, I do not need NAT, but NAT was set to Yes on the PBX and the phone even after I changed that manually on the phone earlier (maybe it is dynamically updated by the server?). After correcting that, I discovered a port issue where the phone was sending registration requests on the wrong port. After correcting those three things, the phone successfully registered to the PBX and now operates as it should.

I did find a lot of helpful resources along the way, perhaps the most useful is here. This Voip-info[dot]org page helped me immensely with editing the basefile of the phone to enable certain features. Hopefully that will help someone else as well.

I appreciate all the responses to this thread, the FreePBX community has been very supportive and a lot more helpful than other forums I have been on. With that, I thank you again for the help!

Hi, just saw ur thread, glad you have resolved your main problem.

Thought I’d give u a heads up regards the 9.x SIP firmware on the 79x1 / 79x2 series of phones, but i Had issues with Connected Line Display not updating the CID once a transfer was completed. I couldn’t figure out why this was, and couldn’t find anyone with the same issue. I resolved it by going back to an 8.x SIP image. I haven’t noticed any difference in performance or features between these releases. I also read that 9.x ditched UDP for SIP, and uses TCP (although I never noticed this, as my exten are all set to UDP Only)…