Cisco 7962 Stuck on Registering

endpoint
Tags: #<Tag:0x00007f7025ebeb90>

#1

(Yes, I’ve already whitelisted all of these phones from fail2ban, that is not the issue)

I’ve got a bunch of 7962Gs and I’m trying to get them configured using End Point Manager (EPM).

When I put the phone MAC addresses into EPM, the phones immediately go and grab the SEP file, which is great, but then they get stuck on the “Registering” loop and never actually register to their proper extension. Here’s the phone’s network log:

4:40:02p Error Updating Locale

4:40:02p Error Updating Locale

4:40:27p 802.1X Authentication: Timed Out

4:42:37p File Not Found : CTLFile.tlv

4:42:37p No CTL installed

4:42:37p SEP123456789 (or whatever the MAC is).cnf.xml

4:42:42p DNS Unknown Host

4:42:42p DNS Unknown Host

The above just repeats until the phone forces itself to restart and then get stuck on registering again. Something is working right because the phones are pulling the config file, but I can’t figure out why they’re not registering.

Do I need to install the usecallmanager patch? Is there a setting I need to change in the extension settings? Please help!


#2

Pretty sure the error is looking you in the face!


#3

Yes, but I’m not sure what to do about it! My other non-Cisco phones configured just fine with the same DNS settings. Not sure what I need to do!


#4

Have a look at the config file in /tftpboot and any hostnames that are within.


#5

How do I get to the /tftpboot file? I’ve never had to before…


(Canada) #6

I had issues with end point manager as well
For me It seemed to be a issue with my extensions password as the phones are extremely picky and need super short passwords unlike what FreePBX generates , I decided to use ChanSccpB / chansccpb manager and had immediate success.

Didn’t have a dns issue though
Just a register loop

I looked at use call manager but ended up going with Chan Sccp B (this uses skinny fw)
You can find the install on github on the wiki that cynjut wrote.


#7

@cogenyk I’m trying to install ChanSccpB now but I’m getting a password field when trying to install the database required… Do you know what it is, cause I can’t find it


#8

You can ssh to your server and find the directory (should be /tftpboot but it might be somewhere else… I am currently looking at a manually-built machine & not distro) and within it you will see your SEP XML files. You can review the file using a text editor, grep, more/less commands, or whatever you are most comfortable with.

Changing to SCCP has its pros and cons which you should consider carefully. The 7962G is far more capable with SIP than the elderly 7960 for example, but still not without quirks. A lot has been written on this forum and elsewhere about various Cisco enterprise phones and FreePBX/Asterisk.


(Canada) #9

I just got basic permissions on the forums an hour ago, and I can finally post links.

If you do decide to go the route with ChanSccpB there’s a specific wiki page for FreePBX https://github.com/chan-sccp/chan-sccp/wiki/FreePBX_Installation, follow and read the instructions as some are optional such as installing the DHCP server etc.

I don’t recall being asked for a password however the wiki I linked was written by @cynjut. I’m relatively new to ChanSccpB so I can’t provide much assistance, i switched to it after trying for about 3 days with my sets in SIP mode

Password wise sometimes with MySQL try blank

You might have to create a custom sip model/change the boot load info on chansscpb if you are using a different firmware then listed as all that comes installed is the other models and the 7960


#10

I was able to get ChanSccpB on without the password (somehow, don’t ask me lol). I installed SCCP on the phones and they magically connected! They work wonderfully.

Only problem is that they’re not responding to intercom or paging… Can that be fixed?


(Canada) #11

I just noticed this issue as well,
If yours doesn’t do anything make sure it’s in a page group.
My phone just rings and won’t auto answer, I’ll play around


(Canada) #12

I have it ringing, when I pickup I’m able to hear the page. but my phones won’t autoanswer.

I’m going to make a new post for this issue.


(Dave Burgess) #13

If you go back to the Wiki entry I wrote for installation, there’s a note in there about adding “under-chin” paging and Intercom. It requires a special context (IIRC, I haven’t looked in a long time) but is relatively simple to set up once you have that custom context available.


(Canada) #14

I’m having issues finding this in the documentation , the only link I can see with under-chin


(Dave Burgess) #15

This thread from Sourceforge has some good hints. It was talking about Asterisk 13, so you should use it for information more than a source of “drag and drool”:

https://sourceforge.net/p/chan-sccp-b/mailman/message/35504841/

This Wiki article should be up-to-date and should answer the rest of your questions:


[ChanSccpB] Auto Answer
(Canada) #16

Thanks so much I’m following the instructions
But database put DEVICE/**<Paging Group\>**/autoanswer macro 1way-paging returns command database not found.


#17

@cogenyk or @cynjut Could one of you guys help me set the auto-answer up? I can’t seem to figure it out.

Also, I noticed that any calls that originate from either a ring group or queue can’t be answered on the Cisco sets. Trying to answer the call just results in it continuing to ring as though it wasn’t answered.


(system) closed #19

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.