Cisco 7960 Provisioned without access calls


(Amr Salem) #1

Hello everybody,

I have a problem with cisco phone 7960, it just provisioned via endpoint manager and takes the assigned configuration but sill not have access to make a call (cannot send or receive calls).

is there any way of solving this case !!?
appreciated your help


#2

Your question is too vague. What troubleshooting have you done?


(Amr Salem) #3

dear billsimon

thank you for replay, I have cisco phone 7960 I am not able to use it on asterisk, phone registered and cannot make a call from or to its (almost busy tone)

  • phone use sip (P0s3 - 8-12).
  • there an extension has assigned to this phone with SIP type protocol.
  • using the Endpoint Manager to manage the phone and assign his template profile.

troubleshooting:
change the SIP protocol type (Sip | pjsip).
change provision port 5060 to any other.
I did make several changes on both (phone and Astresik CM) but the problem still exists.

thanks a lot


#4

Troubleshooting starts with examining logs on both the server and the phone itself, before you go about making a bunch of changes. Otherwise, you won’t know why you’re changing something.


(Dave Burgess) #5

What @billsimon said, but remember that Cisco 79xx phones are among the most challenging SIP phones available when it comes to provisioning. EPM isn’t up to the task, and the SIP image for these phones is limited by the lack of hardware resources in the phone.

Having said that, you need to look at the logs in /var/log/asterisk/full to see what the actual problem is. I’m going to guess that your password is too long (I think 12 characters is too many for many SIP loads). This security risk is another reason that these phones are not recommended for use as a SIP phone.


(Amr Salem) #6

hello Cynjut

i would like to say that it is working now :slight_smile: just i decreased the password digits (less that 10 digits).

thank you very much, I am really appreciated your support


#7

Haha, that stupid password issue bites again. Great guess!


(Dave Burgess) #8

It is, by a huge factor, the problem with someone says “I’m using EPM to configure a Cisco phone.”

The phones hate SIP anyway, and EPM assumes that the SIP device it’s managing is at least “friendly”.

@amrsalime, the point about the password is also a warning. If you allow SIP access to the outside world, you can expect this SIP extension to be hacked within about 72 hours. This is one of the reasons I recommend against using the SIP load and wrote the instructions for installing the Chan-SCCP-B Channel Driver for Skinny phones. It gives you a fully functional phone with state-aware horizontal buttons and other cool features that work without actually hacking Asterisk source.

Search “FreePBX install chan-sccp-b @GitHub” for more information.


(Lorne Gaetz) #9

This is not in any way related to EPM. The SIP secrets are generated independently of EPM and you have the same issue if you are manually configuring the Cisco endpoint. @amrsalime note that the generated SIP secret length is settable in Advanced Settings.


(Dave Burgess) #10

Yes, and no.

If the question also includes words like “Cisco”, “new install”, “can’t register”, “using EPM”, and “Newbie”, my assumption is that they are probably getting jammed up on the “default” 32 (IIRC) password.

You are absolutely correct that this isn’t the “fault” of EPM. It’s just a feature. :slight_smile:


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.