Cisco 7942G stuck registering

Hello, I’ve noticed that multiple people have had this issue, but I have had a hard time finding an answer. The other parts of my XML file are being applied. I flashed it with the newest SIP software available. I’ve tried many different configuration files, and I enabled TCP communications on FreePBX, but it still won’t work. Furthermore, I’ve heard these phones are a pain, but we need to use them. Am I missing something?
XML File:

<?xml version="1.0" ?>
                        <timeZone>Eastern Standard/Daylight Time</timeZone>
                                <member priority="0">
                        <line button="1">

The phone debug menu states:
12:45:15p SEPC0626B6351CC fe80::aa70:5dff:feb9:9721 CP-7942G 1 0 0 0 0 0 4095 -1 1305122179238170636726157048592 14 Sent:REGISTER sip: SIP/2.0 Cseq:107 REGISTER CallId:c0626b63-51cc0007-26d45136-a48d4309 @

If you created a chan_sip extension:
In Asterisk SIP Settings → SIP Legacy Settings → Other SIP Settings enter
tcpbindaddr =
and set Enable TCP to Yes.

If you created a pjsip extension:
Set both Rewrite Contact and Force rport to No.
In Asterisk SIP Settings → SIP Settings
tcp - - All should be Yes. If not, click Yes and hit Submit.
You should then see under (tcp), Port to Listen On. This must match the value of
<port>5160</port> in the <sipLines> section of your XML file

If you still have trouble, at the Asterisk command prompt, type
pjsip set logger on
sip set debug on
according to extension type.
Reboot the phone so it attempts to register, paste the relevant section of the Asterisk log at and post the link here. If you are too new to post links, just post the last eight characters of the URL.

SOLUTION: I just went and used SCCP to setup and manage the phones.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.